TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Nov 22, 2017 10:59 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: amp dead?
PostPosted: Wed Nov 15, 2006 11:14 pm 
Offline

Joined: Sat Sep 18, 2004 11:26 pm
Posts: 115
Location: Wisconsin
So I hooked up my system and this happens: a loud hum and both 30 amp fuses blow on the amp. Keep in mind that the system was already wired from when I took it out and everything worked fine then. So I replaced the fuses and now the amp turns on fine, but their is no sound whatsoever. I tried different audio cables and nothing. I tried a differant sub, nothing. So is it fried and why? Thanks, BTW its a kenwood 800 bridged to two audiobahns.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 25, 2006 2:28 am 
Offline

Joined: Mon Nov 13, 2006 1:14 am
Posts: 107
Location: Winnipeg
are you sure the preouts on your deck are working still?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 25, 2006 11:51 am 
Offline
King of Pompous
User avatar

Joined: Sat Aug 25, 2001 4:22 pm
Posts: 5596
Location: Ottawa ONT.
Yeah check the preouts and then check the impedance that the subs are wired to. Might have to low an ohm load for the amp.

_________________
LNLC Founding Member

FAKE FRIENDS: Never ask for food.
REAL FRIENDS: Is the reason you have no food.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group