TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Tue Nov 21, 2017 11:25 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sun Jul 19, 2009 2:05 pm 
Offline

Joined: Sun Oct 19, 2008 4:03 pm
Posts: 16
Location: Newfoundland
These cars are great! lol. I had some old stereo equipment in the shed and decided since I drive 40 km's to work and 40 km's back I'd like to have some bass for my little car. Now my other car that I had this bandpass box in was my 96 Impala SS, you know, "A BIG CAR". Well I have the box in there and it just fits. I have a little space on each side of the box and the back cover fits over it and you can't tell it's there. Until I turn the thing on 8)

So the set up is a sony Xplod deck with the USB port so I can have my gigs of tunes from the jump drive. aftermarket speakers of unkown quality, a pyramid pb1080 1400 watt 4 channel amp, yeah I know, OLD school, like 1998 lol, and two 10 inch planet audio ???watt subs. the normal speakers are being driven by the deck, but I have the lows turned right down and I have the sub output turned up for the bass. Well I haven't cranked it cause really, I just wanted some bass for my music and I have WAAAAAYYYYY more then enough now. Did I mention these cars are small? :razz: I haven't noticed a drain on the battery with dimming lights and such yet though from what I understand the 1400 watt amp should pull more power then the little alt can dish out.

I have some questions. If I keep the power levels down, I'm not looking for SPL or anything here, will I be in the clear as far as not hurting the battery and alt? I have seen the post on the big three and I see a possible upgrade path there.


Top
 Profile  
 
PostPosted: Mon Jul 20, 2009 6:55 pm 
Offline

Joined: Sun Oct 19, 2008 4:03 pm
Posts: 16
Location: Newfoundland
Guess this needed pictures.

The faces I got today driving to work was priceless. Is that noise coming form the guy with the little car with baby seats?? LOL


Attachments:
100_3372.JPG
100_3372.JPG [ 252.9 KIB | Viewed 1707 times ]
100_3374.JPG
100_3374.JPG [ 208.6 KIB | Viewed 1706 times ]
100_3375.JPG
100_3375.JPG [ 196.26 KIB | Viewed 1706 times ]
100_3376.JPG
100_3376.JPG [ 203.61 KIB | Viewed 1707 times ]
Top
 Profile  
 
PostPosted: Mon Jul 20, 2009 7:41 pm 
Offline
User avatar

Joined: Mon Jun 18, 2007 1:35 pm
Posts: 2433
Location: Regina, SK
LoL,

I'm jealous of the cargo cover... $250 from the dealer keeps me shy... :lol:

_________________
My cars:

J. McBean: '98 Suzuki Swift 1.3L 16v SOHC 5sp+ "Mk5" Made in Canada
The Mini Rattler: '94 Suzuki Swift .993L 6v SOHC 5sp+ "Mk3" Made in Canada *The Winter Beater*
B. Berry: '90 Chevrolet Turbo Sprint 1.0L 6v SOHC 5sp+ "Mk2" Made in Japan

I got 18MPG in a 3cyl with a 5 speed manual 4dr, '93 Metro! :yeahyeah


Top
 Profile  
 
PostPosted: Tue Jul 21, 2009 1:39 am 
Offline

Joined: Sun Oct 19, 2008 4:03 pm
Posts: 16
Location: Newfoundland
Wow 250 bucks!!! I'm glad I have mine then and that the previous owner didn't lose it.


Top
 Profile  
 
PostPosted: Thu Jul 23, 2009 5:01 pm 
Offline

Joined: Sat Jun 20, 2009 4:15 am
Posts: 12
Location: Oregon
Be lucky to even get 800w RMS out of that amp, lol.
I'm running about 1200w in my Geo and holy crap.... Alt belt squeals like crap, voltage goes to 11.8v, probably be better once I can get this new belt in.


Top
 Profile  
 
PostPosted: Sat Jul 25, 2009 4:11 pm 
Offline
User avatar

Joined: Wed Apr 01, 2009 2:21 am
Posts: 87
Location: Lacey, WA. USA
I've got an MTX 250w running a 12" pioneer sub in a bandpass box. That alone is enough to rattle the crap out of things. Doesn't seem to drag the voltage down either.

The same setup was never loud enough in my old Escort GT. I do love the acoustics in these cars lol!

_________________
1992 Geo "TIE Fighter" Metro 1.0 SOHC 5sp.
Image


Top
 Profile  
 
PostPosted: Sun Jul 26, 2009 8:32 pm 
Offline
Sad but True...

Joined: Fri Jul 27, 2007 8:20 pm
Posts: 2973
Location: Saskatchewan
with good wiring and a optima battery on a stock alt I have no problems running 1200w amp. I dont even dip below 14 when its above 1500rpm. and im underdriving my alt too! that said, im not using 1200watts at all times, I dont have it cranked up that much, so its probably a 600watt ish load on a daily basis. but when its all the way, yeah it dims.

but assuming you dont run your amps at max volume at all times, the actual wattage rating doesnt mean much. sure if its only a 400watt amps thats as high as it goes, you just have to be careful. running 1200watts off a 770watt alternator wont last too long, thats why I think its important to atleast put a quality dry cell in there

no belt squeel and im using the 3rib system not 4.

_________________
1991 Swift GT Build G10 +25 psi + other goodies
1996 Metro Build QR25de swap, still undecided where to take it
the lolcar family


Top
 Profile  
 
PostPosted: Tue Jul 28, 2009 5:00 pm 
Offline

Joined: Sun Oct 19, 2008 4:03 pm
Posts: 16
Location: Newfoundland
Thanks for the replies. Yeah I know its not the best amp, and it probably doesn't push the 1400 watts that it says it is but that matters not. I have yet to dim the lights and I've had it plenty loud. Just today driving home a lady looked over while I was playing "prodigy firestarter" and she looked me right in the eyes and shook her head. I laughed. It was just the response I was looking for. Little car, babyseats, and loud music, it really is funny. :lol:

So the alt puts out 770 watts. I'll have to keep that in mind. I have not cranked it to max yet. I found a dash rattle :wink: though, I might drive a screw down to hold the part in place for the high bass songs. For the most part there are a lot less rattles on these cars then many domestics from that year.
Keep the music pumping, oh and I love how subs less then 3 feet from the back of your seat almost give you a massage 8)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group