TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Thu Nov 23, 2017 4:04 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: High ldle problem
PostPosted: Sat Apr 02, 2016 6:48 pm 
Offline

Joined: Tue Dec 17, 2013 12:02 pm
Posts: 22
Location: Madison, WI.
My car recently started a high idle every time I come to a stop. 91 vert auto trans 300k miles. It reacts as though I just started the engine and its cold even though it's up to full operating temperature. I just pop it into neutral and it slows down to a normal idle in about 10 seconds or so.

My mom is going to borrow my car for a couple months and she's not going to pop it into neutral like I do and I'm worried about it burning out my antique transmission. So I'm looking for suggestions of what you guys think maybe causing the high idle. 2000rpm

Also, after the engine slows down and I shut off my dash fan it'll rev back up to 2000rpm.

Bone stock unaltered engine except for ignition coil.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group