TeamSwift
http://www.teamswift.net/

NEW TOMS II chip dyno tested against rally chip!!!
http://www.teamswift.net/viewtopic.php?f=17&t=42808
Page 2 of 2

Author:  crnolic [ Fri Aug 28, 2009 9:27 pm ]
Post subject:  Re: NEW TOMS II chip dyno tested against rally chip!!!

pm sandro

swifty92

Author:  Swifted [ Wed Sep 23, 2009 7:06 pm ]
Post subject:  Re: NEW TOMS II chip dyno tested against rally chip!!!

Swifted wrote:
crnolic wrote:
i just put my swift on the road today after sitting for a year
drove to toronto to pick up sandros chip
i previously had toms chip installed and it was a big difference from stock
and sandros chip is even a bigger difference from toms
car pulls A LOT harder and quicker
from about 4k to 8k+ much quicker than toms chip
runs a bit richer
idles very nicely at 900rpm with 340/210 cams

two tumbs up for this chip. 8)


is there any way that this chip can be ordered online? can I see a weblink if available?


EDIT:

I Just received the Sandro's Chip yesterday, and fitted it this morning... BRILLIANT!!!

...I also get the check engine light, but the car is not in limp home mode. It pulls very hard from idle and gets very strong when the cams come in around 3,500~4000 and climbs hard to my fear induced limit of 8,000rpm! lol

I upgraded from the standard chip, so I'm seeing a night & day difference in the way the car responded to the upgrade. There is a bit more fuel present for sure, as my AFR gauge is no longer lingering off the scale towards lean. All in all, I am quite pleased with the Chip and happy to have had a great buying experience from Alessandro.

Cheers!
Daniel

Author:  djaggs [ Tue Sep 29, 2009 9:27 pm ]
Post subject:  Re: NEW TOMS II chip dyno tested against rally chip!!!

Ive noticed that when I installed the Toms chip in my car the ignition becomes way too advanced to the point that i get a lot of pinking.

I also noticed that there wasnt any hp improvement on the dyno. The car did accelerate better, but i expect that was from the advanced ignition timing.

The only other modifications were cultus cams, cultus pistons, cultus extractors (headers) and 2 inch exhaust.

Without the chip the engine runs fine with no pinking.

Can anyone say if the Toms II chip improved on this area??

Author:  Knuckles [ Tue Sep 29, 2009 9:37 pm ]
Post subject:  Re: NEW TOMS II chip dyno tested against rally chip!!!

Have you tried retuning your car with the chip to get the best timing advice curve for the chip.
just putting the chip in that was designed for an engine setup different than stock can make all the issues you have found happen.
Not knowing the programming in the new chip, can be a problem also.
What octane fuel are you using, is also a question you need to ask.
I have a 1st gen Toms chip in a spare ECU came with one of my 89's.
Works great with a stock motor with CAI and header with decent exhaust.
running regular fuel it pings running hi octane premium it won't.
Phonominal response in the 3500 up range rpms, plus great top end.
driving around the city not so good.

Page 2 of 2 All times are UTC - 5 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/