TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sun Nov 19, 2017 10:00 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Fri Sep 20, 2013 12:34 am 
Offline

Joined: Sat Aug 31, 2013 2:53 pm
Posts: 7
Location: vancouver
I have a 93 swift no spark or power to fuel pump changed fuse box under dash and in engine comp fuel pump relays no luck is there a simple solution tried a different computer nothing.
Thanks


Top
 Profile  
 
PostPosted: Wed Oct 23, 2013 4:22 pm 
Offline

Joined: Wed Oct 23, 2013 4:12 pm
Posts: 1
Location: Croatia
I had a same problem. Check the connectors, mine had fallen of. :)
It's not much but maybe it helps. :)


Top
 Profile  
 
PostPosted: Wed Oct 23, 2013 6:49 pm 
Offline
User avatar

Joined: Thu Jul 09, 2009 1:14 am
Posts: 1897
Location: Prince George B.C. Canada
Check your grounds.


Top
 Profile  
 
PostPosted: Wed Oct 23, 2013 7:03 pm 
Offline

Joined: Sat Apr 24, 2004 9:48 am
Posts: 725
Location: Winnipeg
top down@-40 wrote:
Check your grounds.


+1 for check your grounds!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group