TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Nov 22, 2017 5:17 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Sat Apr 26, 2014 11:04 am 
Offline

Joined: Sat Aug 31, 2013 2:53 pm
Posts: 7
Location: vancouver
It's a living nightmare took the harness of a 92 to try on a 93 swift that wouldn't start gave up put everything back on 92 now it won't start. Turn the key the fuel pump doesn't prime and no spark when cranking. changed the ecm both fuse boxes distributor relays checked all the grounds took the 93 to a good mechanic I trust he gave up after 2 hours. I'm hoping it may be something simple that I've over looked have to get car out of the place or scrap it.
if someone could please help thanks


Top
 Profile  
 
PostPosted: Tue Apr 29, 2014 6:33 pm 
Offline
User avatar

Joined: Sun May 05, 2013 3:50 pm
Posts: 28
Location: Colorado
I've had the same problem twice, once on a 93 and once on a 94. No fuel pump and no spark. The 94 was a bad ground off the main relay. The 93 was and odd one, the wire running from the egr sensor had worn through it's coating and shorted out on the wire holder causing the main relay fuse to keep blowing. Neither were easy to diagnose AT ALL. At one point I had the left front fender off and every harness completely stripped apart to test continuity to the various wires. This took WAY more that 2 hours. I was into it for a couple days before I figured it out. The egr sensor sits on the driver side of the intake manifold and the wires run straight down to a flexible wire retainer mounted to the top of the transmission. Check there to make sure they are not shorting. Also replacing the main relay, relay fuse, and running a new ground off the main relay are all good ideas and simple enough to do. Forget chasing the old relay ground, it is a serious pain. Hope this helps!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group