TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Mon Nov 20, 2017 5:12 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: dodgy backend
PostPosted: Wed Dec 28, 2005 4:23 pm 
Offline

Joined: Mon Nov 21, 2005 7:08 pm
Posts: 18
Location: bristol
im having a problem wit my 1990 swift gti. when going over bumps i can feel the backend kicking out. i have adjusted the rear caster as close into spec as i can, it is lowered 40mm and its got powerflex polybushes on the rear.
can anyone suggest anything else i can do??


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 28, 2005 4:42 pm 
Offline
User avatar

Joined: Tue Jul 20, 2004 7:17 pm
Posts: 3566
Location: Georgetown, Guyana
AFAIK - caster is not adjustable on these cars, at either end. The only adjustment possible with the standard suspension is toe-in/out.

I don't think camber is a problem on the back end of these cars with lowered suspension, so I'm guessing what you need is a good four wheel alignment job.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 28, 2005 7:48 pm 
Offline
User avatar

Joined: Tue Mar 16, 2004 6:23 am
Posts: 1750
Location: Washington, DC
Those links adjust toe in/out.

_________________
91 Pontiac Firefly Turbo
10 Suzuki Kizashi


Alcohol, Tobacco, and Firearms
Should be the name of a convenience store, not a government agency


Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 28, 2005 11:06 pm 
Offline

Joined: Sun Dec 18, 2005 12:18 pm
Posts: 8
Location: pa
Jeez Woodie.You have my two dream cars.

_________________
S.U.V.'s suck (up a lot of gas)


Top
 Profile  
 
 Post subject:
PostPosted: Thu Dec 29, 2005 4:08 am 
Offline
User avatar

Joined: Mon Nov 15, 2004 6:23 am
Posts: 291
Location: Oakland, CA
I had this problem back about a month ago with my wife's vert. it was a bad strut. really wore the tire on one side with lotsa camber wear. I replaced the strut, and everything is back to normal again, driving straight without swaying or kicking out and the back end swinging around.

I got the struts offa ebay, really cheap and they ship fast. search under parts & accessories for "metro struts". it was oem suzuki/gm strut.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Bing [Bot] and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group