TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sat Nov 18, 2017 5:35 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: gauges! need help!
PostPosted: Sun Jul 05, 2015 8:59 pm 
Offline

Joined: Sun Jul 05, 2015 8:37 pm
Posts: 3
Location: United states
I have an 87 sprint turbo with the mk 1 gauges and on a trip about a week ago the temperature and fuel pointers go past full and hot makes. They both messed up at exactly the same time. It's been driving me crazy trying to figure it out. I've tested the fuel pump and temp gauge and both work properly, as well as diagnose the fuse block. I noticed a jumper wire on another post on the back of another mk 1 gauge and tried it, but that will stop the coil from working. I've traced grounds and everything comes back to instrument cluster must be messed up? Any solutions or possible fixes?


Last edited by sims88anime on Mon Jul 06, 2015 10:19 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: gauges!
PostPosted: Sun Jul 05, 2015 9:08 pm 
Offline

Joined: Sun Jul 05, 2015 8:37 pm
Posts: 3
Location: United states
[album][/album]


Attachments:
KINDLE_CAMERA_1435694669000.jpg
KINDLE_CAMERA_1435694669000.jpg [ 127.05 KIB | Viewed 501 times ]
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group