TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sat Nov 18, 2017 1:27 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: No washer fluid
PostPosted: Thu Nov 19, 2015 1:11 am 
Offline

Joined: Fri Dec 05, 2014 11:23 pm
Posts: 143
Location: SK
Picked up a new project, a 91 vert with a t3 swap, and the washer fluid is not working. The wiper works when I hold the button however the pump will not activate. I checked the voltage at the connector to the pump and it showed 0.05 volts, I also tried with a different ground and got the same.

The previous owner told me they swapped the entire front engine harness, as they were unaware of how to wire the igniter in. It appears that the pump was cut out and spliced back in. It is all soldered and heat shrinked properly, however it looks like there are 3 wires that branch off from the harness. 2 are connected to the pump, the third has been cut and is just hanging. I believe the extra wire is black with a brown stripe. I'm thinking it may be a ground. But I am not sure. Hopefully I can get some clarification on which wire is which and what else I should check to trouble shoot.

Thanks


Top
 Profile  
 
 Post subject: Re: No washer fluid
PostPosted: Thu Nov 19, 2015 8:59 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
there are two pumps on a t3 car, one front and one rear. they might have hooked up the wrong power wire.
check the 3rd wire for power when the pump switch is activated.

my 1990 fsm shows blue/yellow front pump, black/green rear pump.

1990 electrical fsm shows blue/black front pump, black/green rear pump

1989 t3 fsm shows black/green front pump, blue/yellow rear pump

solid black being ground.

there have been typos in the books. why it shows them reversed from n/a to t3, I have no idea. :huh:
check body grounds on inner fenders, both sides near front.
good luck! :wink:

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group