TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Thu Nov 23, 2017 8:52 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Mon Jan 11, 2016 12:10 pm 
Offline

Joined: Fri Jun 03, 2005 11:37 pm
Posts: 124
Location: Oregon
I recently bought a 1999 Suzuki Swift 1.3l 4cyl 16v AT(and AC) with high miles.
I bought it in non running condition.
The mechanic diagnosed and fixed a broken flexplate.
The car smokes at first start up and possibly on hard exceleration.(no moisture at the tailpipe.)
The oil is clean as is the antifreeze.
I did the "sizzle" test.Placed oil from the engine on a hot plate and it bubbled and sizzled indicating water in the oil.
I took the car for a drive(approx. 120 miles.) It ran beautifully.It excelerated on steep hills and idled smooth.
Does this sound like a head gasket or bad rings?
Also,there seems to be no supplier of head bolts for this vehicle??

thank you


Top
 Profile  
 
PostPosted: Mon Jan 11, 2016 1:40 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sun Feb 23, 2003 4:16 am
Posts: 8044
Location: Ontario, Canada
Very common with those motors. Likely valve seals or guides.

If it runs OK, just drive it.

_________________
Contact 3tech: g10pro@rocketmail.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group