TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Nov 22, 2017 11:40 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: No turn signals
PostPosted: Tue Feb 23, 2016 2:42 pm 
Offline

Joined: Fri Dec 05, 2014 11:23 pm
Posts: 143
Location: SK
Turn signals stopped working today. The car is a 91 vert with wiring harness from a 91 t3. Hazards work fine, brights turn on and off from the column switch.

What should I replace first?


Top
 Profile  
 
 Post subject: Re: No turn signals
PostPosted: Tue Feb 23, 2016 3:32 pm 
Offline
User avatar

Joined: Tue Feb 28, 2012 4:35 pm
Posts: 828
Location: Hamilton, Canada
The whole column switch might need to be replaced

_________________
___________________
89 Swift gti
Modified B16 P29 75mm pistons,13:1CR, cultus intake, genie header, genie exhaust, 3tech head, 3tech 222/365 cams, 3tech UD pulley, megasquirt 2.0, 60mm throttle body, Aluminum flywheel


Top
 Profile  
 
 Post subject: Re: No turn signals
PostPosted: Fri Feb 26, 2016 2:09 pm 
Offline

Joined: Fri Dec 05, 2014 11:23 pm
Posts: 143
Location: SK
Plugged in a good working column switch but made no difference


Top
 Profile  
 
 Post subject: Re: No turn signals
PostPosted: Fri Feb 26, 2016 8:45 pm 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11675
Location: columbus, ohio
i'd start with the more simple and less expensive things like the turn signal flasher relay. :wink:

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
 Post subject: Re: No turn signals
PostPosted: Sat Feb 27, 2016 1:21 pm 
Offline

Joined: Fri Dec 05, 2014 11:23 pm
Posts: 143
Location: SK
It wasn't exactly an expensive fix as I have 4 sprints ha ha ha.. I didn't completely install the switch, just plugged it into the fuse box. I can't see it ymaking a difference unless is the switch is grounded through the steering column the same way the horn is?

My hazard lights still work fine, do they not run off the same relay as the turn signals? If the relay was no good my hazards would stop working, correct?


Top
 Profile  
 
 Post subject: Re: No turn signals
PostPosted: Mon Mar 21, 2016 1:56 pm 
Offline

Joined: Fri Dec 05, 2014 11:23 pm
Posts: 143
Location: SK
After replacing the relay and signal switch they still do not work. Hazard lights work fine.


Top
 Profile  
 
 Post subject: Re: No turn signals
PostPosted: Tue Mar 29, 2016 2:49 pm 
Offline

Joined: Fri Dec 05, 2014 11:23 pm
Posts: 143
Location: SK
I have now replaced the column switch, relay and hazard switch all from a parts car with known working signal lights. Hazard lights still work fine. There is no apparent buzzing when activating the signal light. I could not find any burnt or melted connectors in the wiring harness.

Amy suggestions would be much appreciated


EDIT:

Upon closer inspection I found the fuse to be blown! Next time I will completely remove my fuses to test them rather than leave them in the box and just look.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group