TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Fri Nov 24, 2017 1:28 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: I NEED HELP!!! PLEASE!!!
PostPosted: Mon Oct 09, 2006 12:57 pm 
Offline
User avatar

Joined: Mon Oct 09, 2006 12:13 pm
Posts: 19
Location: las vegas
PLEASE HELP ME!
I have an 87 chevy sprint turbo with 100,000+ miles on it & I LOVE THE CAR!! but ive been having a few consistant problems lately:
1. there is a knocking around the block somewhere (could it be a piston? camshaft?)
2.i have problems shifting into first gear. do i need a whole new tranny or can i just replace the clutch itself?
3. this is the big one! heres what happened the other day: the car wasnt sounding right in the morning, and i have it set to idle at 1200rpms, but the other day it was bouncing from 900-1200 and coughing a little everytime i stepped on the gas. so i checked the spark plug wires cuz i had problems with them slipping off before. I pushed them all back in and it seemed to fix the problem BUT THEN: when i drove up onto the freeway i started to speed up and heard a loud pop!! i lost nearly all power and had to coast at like 15mph to the next exit. When i got off i checked the motor & it was fine EXCEPT the first spark plug had shot out of the head and was dangling at the end of the plug wire :shock: ; AND the second plug wire had popped out as well!!! I managed to shove the second wire back onto the plug and sputtered down the road to an AutoZone where i asked the service rep to help me get the first plug back in. He helped me but said that the thread in the head was stripped & would need to be resurfaced & that the same problem might happen again! WHAT SHOULD I DO? :?
I want to get a new head but im afraid if i get a new one: it might throw off the rest of the motor since i have all original parts on it. would the bottom end be able to handle it? should i just get a brand new motor? or just resurface the head? i know a few of you sell rebuilt motors! & i wanted to tune the motor i have but its been falling apart! so i need some help... what do you think?
thanks
-alex-


Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 10, 2006 12:54 am 
Offline
Moderator & FAQ King
Moderator & FAQ King
User avatar

Joined: Wed Apr 09, 2003 6:22 pm
Posts: 6460
Location: Vancouver, BC
Your transmission problem may just be a weak synchro. Try a fluid change to GM Synchromesh, and if that doesn't work, try double-clutching.

Like it or not, your cylinder head needs to come off to get fixed. My suggestion would be to send it down to 3Tech (see banner @ bottom of page) to be properly looked after.

_________________
jaguar,vettes&sprints wrote:
...can you inlighten me about lihtan's
( miracle pour hole)
maybe a picture Thanks


Top
 Profile  
 
 Post subject:
PostPosted: Tue Oct 10, 2006 1:07 am 
Offline
User avatar

Joined: Tue Jan 03, 2006 9:34 pm
Posts: 1787
Location: Willow River B.C.
You can get a helicoil put in for the stripped plug hole and it is recommended to remove it to prevent getting aluminum shavings in the cylinder (although I have seen people do it with the head on..) no resurfacing required and if its properly installeed shouldnt be a problem again.

Synchromesh works wonders, go to the GM dealer and ask for it. 2.5L's worth for your trans.

Is it a knocking or a clicking coming from the engine? valves may just need to be adjusted.

Get a new set of plug wires.


Scott

_________________
Its not lag, its suspense...
1987 mk1 T3


Top
 Profile  
 
 Post subject: thanks
PostPosted: Wed Oct 11, 2006 12:19 am 
Offline
User avatar

Joined: Mon Oct 09, 2006 12:13 pm
Posts: 19
Location: las vegas
thanks for all the help guys!!
Lihtan: The Synchromesh sounds GREAT!! can only i get it exlusively at a GM Dealer? or can i get it at any auto place like a PEP-BOYS or AutoZone? & how long would it take for 3Tech to hook up my head? cuz i did a little searching on the page & was wondering if it's still a week to a week and a half turnaround? & $375+part+shipping?
TbirdScott: Thanks for the tip on the helicoil!! Also: its a knocking / clacking sort of noise in my block not really a clicking.
Thanks again for all the help guys!!!
-alex-
ps. I'll be sure to get some new wires!! mine are kinda old :x !! hahaha


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 11, 2006 1:36 am 
Offline

Joined: Sat Oct 11, 2003 7:44 am
Posts: 451
Location: near Burbank, Calif
Just have somebody (competent in head tapping) install a Helicoil in the head without removing it.
After it is installed, still leaving the plug out, go ahead and start it up.
Rev it up a bit and all the loose metal chips will be blown out.
Then put the spark plug back in and it should be ok.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group