TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Nov 22, 2017 1:23 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: ELECTRICAL PROBLEM
PostPosted: Sun May 19, 2013 10:33 pm 
Offline

Joined: Wed Apr 02, 2008 2:34 pm
Posts: 1
I have installed a 1990 Suzuki Swift gti in my 1991 Geo Convertible. I switched the engine and the wiring harness and the ECM. All went well but now I cannot get power to the distributor. The car ran fine before I took it out of the donor. I've checked all the connections and grounds and can find no reason why I can't get power to the distributor. Can you give me any help? Also where would I find a wiring diagram for the electric on the GTI? Thanks Alberta Slim


Last bumped by our65pu on Sun May 19, 2013 10:33 pm.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group