TeamSwift
http://www.teamswift.net/

Suzuki Swift twin cam in need of tech help
http://www.teamswift.net/viewtopic.php?f=27&t=54573
Page 1 of 1

Author:  Oldskoolimport [ Mon Sep 24, 2012 12:36 pm ]
Post subject:  Suzuki Swift twin cam in need of tech help

Hello Everyone,

Really in need of help with my swift project It's a 1993 geo metro xfi with a swift twin cam swap. Brief history on the car bought it with the swap but had a blow motor. Head was off wire's all over the place. I bought a motor and dropped it in the car. Try to start it but it's really hard to start and run's rough the symptom's are. Hard to start once it does start willnt pass 2000 rpm Sometime when it does start, it start's up rev up to 3000 and shut's right off. The factory air intake plactic was taped and in bad shape i shopped around found suzukird. I bought a 3 stage air take took month's to get here put it on and still the same. I'm thinking it might be the maf sensor i'm hoping someone might be able to help me. I have had this car for a while and have never even drove it. Can use a vacuum diagram need to check to see if that's all in order. I'm in new jersey if there's anyone in my area would love to run together once i'm on the road Thank's in advance.

Author:  suprf1y [ Mon Sep 24, 2012 2:40 pm ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

Moved to the correct forum.

Author:  t3 ragtop [ Mon Sep 24, 2012 4:43 pm ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

the symptoms you describe point to the ecu being in "limp home" mode. it probably needs a good ecu after you get the wiring straightened out.

Author:  Oldskoolimport [ Tue Sep 25, 2012 11:45 pm ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

Thank's ragtop for the information, Do you know if i can use any year ecu on my car from 1989 to 1994? And is there anyone on here that can maybe repair the one i have. Thank's again

Author:  t3 ragtop [ Thu Sep 27, 2012 4:52 am ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

i've been able to recover 2 ecus out of about 30, patching a main ground trace on one and replacing a protective diode on another. the rest were toasted too badly to fix.

the connectors from all the gt cars, 89 thru 94, fit any of the ecus and i never had any troubles running a mk2 ecu in a mk3 car and vice versa. some guys prefer the fuel and ignition mapping on the later model cars.

Author:  pvt_pwn [ Sat Sep 29, 2012 2:35 pm ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

Did you change the fuel pump?

Author:  t3 ragtop [ Sun Sep 30, 2012 9:13 am ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

the key symptom here is revving to 3000 rpm and shutting down. that's the indication of "limp home" mode and a damaged ecu. the engine will rev right to 3000 rpm and the ecu performs a hard rev limit shutting down injection and ignition.

a bad fuel pump or crapped up fuel filter doesn't cause that exact symptom.

you can read the factory service manual's troubleshooting section and see the exact parameters of failure that oldskool describes.

Author:  crnolic [ Sun Sep 30, 2012 10:24 am ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

i would definetly check the maf and maf wiring.

http://home.cogeco.ca/~crnolic/swift_MAF.pdf

Author:  pvt_pwn [ Mon Oct 01, 2012 8:26 pm ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

Hmm. From the original post, it sounded like the car fired and revved to 3k on its own. I may have been looking too far into it, but thought it may be the underlying problem, in addition to lack of fuel when the engine needed it. (again, probably over-thinking it)

...your technical expertise never ceases to amaze me, T3. :oops:

Author:  t3 ragtop [ Tue Oct 02, 2012 5:04 am ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

thanks, but it isn't technical expertise. it's right from the troubleshooting chart in the factory service manual. :wink:

when i did my first swap i had to work through the dead ecu thing and it acted just like that, revved to exactly 3000 rpm and did a hard spark and fuel cut. if i pumped the gas pedal before the engine died, it'd catch and run again up to 3000 rpm and cut out.

a new ecu cured it. :D

Author:  jaguar,vettes&sprints [ Wed Oct 03, 2012 4:40 am ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

and when you plug in your new to you ECM make sure the Battery is disconnected

Author:  Oldskoolimport [ Thu Oct 04, 2012 2:50 pm ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

Hi

Just wanted to thank everyone for all the information i'm hoping to get to work on this month sometime.

Author:  michael MI [ Fri Dec 13, 2013 12:26 pm ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

Do you still have the ECM unit out of the Xfi

Author:  fainya [ Tue Jul 07, 2015 3:12 pm ]
Post subject:  Re: Suzuki Swift twin cam in need of tech help

I dropped a 92 DOHC into my 97 geo. I used 98 wiring harness to get sequential fuel injection.
I could not get the engine to rev past 3,000. It turned out to be a cam sensor issue.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/