TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Fri Nov 24, 2017 6:11 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sun Aug 04, 2013 11:12 am 
Offline
User avatar

Joined: Thu Dec 15, 2011 1:11 pm
Posts: 27
Location: Toronto, Ontario
I'm in the middle of an engine swap from my '94 g10 upgraded emissions to a g10t from a '90 chevy sprint turbo. Everything is done except I'm having a problem with the wiring. When I turn the key to on, I get no fuel pump priming, and no CEL. There is no CEL when I put a fuse in the diagnostics port either. I try to start it and it will crank, but there's no spark or fuel. Here's pictures of the wiring I have spliced together so far. This may be a little long-winded but I'll try to explain it as well as possible.

For the connector by the engine fuse panel, I used the mk3 connector (left in below pic). The mk2 connector had 7 wires. I matched 5 colour to colour into the mk3 plug, and ran the orange and yellow wires to the igniter. I didn't use the black, red/green, yellow, brown, or brown/yellow wires from the mk3 connector.
I also didn't use this 6 pin connector at all. Can someone tell me what this connector is for (right in below pic)?
Image

For the igniter, I have the orange and yellow wires coming from the engine harness, a black/white wire coming from the chassis harness and going to the igniter and + on the coil in parallel, a brown/white going coming from the noise suppressor and splitting to go to the - on the coil and the igniter.

The mk3 igniter had extra wires, so I have a black wire and brown/yellow wire that used to go to it taped off.

Inside the cabin, I used the mk3 connector for the instrument cluster. I swapped the pins from the green plug to the clear one from the mk3
Image
I swapped those colour for colour as well with the exception of a black/yellow wire from the mk2 engine harness being spliced into a black/white wire on the mk3 dash connector. The wires on the mk3 plug I didn't use were purple/white, purple/red, and brown/yellow.
Image

Does anyone that's done this kind of swap seen anything I've done wrong? I could really use some help here. Other things to note: I didn't have the fuse panel or ecu bolted up the first time I tried to start it so it wasn't fully grounded. I also didn't have the ground on the trans bolted on and when I turned the key the FI / fuel pump relay started clicking nonstop. Idk if that would damage anything but I checked all the fuses. The 30A fuse up by the diagnostics connector at the top of the firewall was blown. I didn't think that fuse was needed with the mk2. What is that fuse for?

What do you guys think?

_________________
1994 Geo Metro Turbo
ImageImageImage


Top
 Profile  
 
PostPosted: Thu Aug 08, 2013 9:01 am 
Offline
User avatar

Joined: Thu Dec 15, 2011 1:11 pm
Posts: 27
Location: Toronto, Ontario
Yeah, I figured only someone who's done this swap would really have an understanding of what I was talking about.

Just to update:
I ended up getting it running. The ecm wasn't getting 12v key on power to the +b terminal. I traced it back to the EFI relay. There was a blue/black wire on the relay that wasn't grounding. I ran a new wire to that pin and grounded it straight to the chassis, and it fired right up!

_________________
1994 Geo Metro Turbo
ImageImageImage


Top
 Profile  
 
PostPosted: Fri Aug 09, 2013 9:03 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11675
Location: columbus, ohio
andrew,

isn't it a great relief when you turn the key and your engine swap project starts and runs?

good job! :wink:

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
PostPosted: Sun Aug 11, 2013 11:03 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11675
Location: columbus, ohio
i saw this car at geopalooza yesterday and andrew did a great job of getting the swap finished and the car running for the drive to the meet.

it looks great in person. good job on that, sir.

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group