TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Fri Oct 20, 2017 9:45 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Wiring Woes
PostPosted: Tue Dec 02, 2014 7:42 am 
Offline

Joined: Tue Oct 28, 2014 6:37 pm
Posts: 62
Location: Antigua and Barbuda
Hi all. I just recently bought a swift gti. the engine starts and runs nicely, but the center console lights work when they want to; the door open alarm works when it wants, fog lights don't turn on; the tach reads inaccurately at high revs, and most recently the horn quit working. I think its loose wiring/grounding. Trouble is I don't know where to start. All suggestions are welcome!


Top
 Profile  
 
 Post subject: Re: Wiring Woes
PostPosted: Tue Dec 02, 2014 5:14 pm 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11669
Location: columbus, ohio
i agree that you probably have grounding issues. the suzuki variant chassis act super wierd when you
have a bad ground. the circuits back feed creating ground loops when they have to find their own path to ground.

you will have to start at the beginning and work to the end. :lol:

i start at the battery with the biggest grounding points - the battery post, the lug on the transmission, the ground wires to the inner fenders on both sides of the engine bay, the ground wire from near the distributor to the firewall, and on until i reach the rear lights.

i even add grounds to carefully chosen points. i use a common ground plate connected directly to the battery - post and run 8 gauge cables from that to those points on the inner fenders, the distributor mounting casting, and most of the additional powered systems i use for lighting and stereo.

i take every ground loose, clean the ring terminals with fine grit emery, clean the painted mounting points under the ring terminals, and use a stainless bolt or screw to replace oem hardware. every ground point also gets a little electrical grease to keep corrosion from re-occurring. i usually add a suitable internal star washer between the ring terminal and chassis metal.

the symptoms you describe indeed point to a weak electrical system and most probably grounds.

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group