TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sun Oct 22, 2017 6:01 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sat Mar 03, 2012 6:06 pm 
Offline
User avatar

Joined: Sun Mar 14, 2004 12:49 pm
Posts: 189
Location: Monroe, WA
I finally got the exhaust back on and drove the car down to the gas station and filled 'er up. It's still running a little low on power past half throttle and I'm not sure why. It goes rich and puddles up is all I can think of to describe it. It has new plugs, cap, rotor, and recent wires to go along with the engine rebuild. I also replaced the MAP and swapped in a different injector this week with no real change. It runs perfect from an idle up to 3k then right to .900+ mv on the O2. Just trying to look into other things that might be making me look in the wrong places...

_________________
Malcolm

'95 Metro 1.0 / 5 spd
165,000 miles


Top
 Profile  
 
PostPosted: Sun Mar 04, 2012 2:33 am 
Offline
User avatar

Joined: Sun Mar 14, 2004 12:49 pm
Posts: 189
Location: Monroe, WA
The more I think about it, I think the computer is going out of closed loop but what could do that without turning on the CE light??

_________________
Malcolm

'95 Metro 1.0 / 5 spd
165,000 miles


Top
 Profile  
 
PostPosted: Tue Mar 06, 2012 12:44 am 
Offline
User avatar

Joined: Sun Mar 14, 2004 12:49 pm
Posts: 189
Location: Monroe, WA
Ok, I guess they don't go out. :)

_________________
Malcolm

'95 Metro 1.0 / 5 spd
165,000 miles


Top
 Profile  
 
PostPosted: Fri Mar 09, 2012 9:30 pm 
Offline
User avatar

Joined: Thu Jul 09, 2009 1:14 am
Posts: 1897
Location: Prince George B.C. Canada
I've had 8, 95 and up cars. Never had a problem with coils. Only had 3 that were DD cars and one I sold to a friend before I even started driving it, the others were running parts cars.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group