TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Fri Oct 20, 2017 12:08 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Mar 29, 2012 3:43 pm 
Offline

Joined: Sun Jul 02, 2006 11:23 am
Posts: 10
I just bought this Swift,1.3L 5spd, it was not running when I got it but found that the copper wiring in the distributor had come or and was wrapped around the shaft. After replacing the distributor the car started easily but idled a bit rough and Bogg bogs down and backfires at high rpm. I replaced spark plugs, wires, fuel filter, timing belt afterwards just cause I knew it had been sitting for a year or more and while it did seem to improve slightly it still does basically the same thing. I also noticed that my brake pedal is very stiff and does very little to stop the car. I checked the vacuum pressure on it and it flutters around 15psi and jumps to a steady 20 psi under acceleration. It defense like I have a leak somewhere but have checked all over without finding anything. Any ideas or advise would be very helpful. Thanks- Josh


Top
 Profile  
 
PostPosted: Thu Mar 29, 2012 9:00 pm 
Offline
Island Inbreeder
User avatar

Joined: Tue Oct 18, 2005 6:56 pm
Posts: 6347
Location: Emerald city Washington
I foun the vacume line to the booster was clogged not leaking
Check it out remove hose and try to blow through it.....jv&s
.
.


Top
 Profile  
 
PostPosted: Fri Mar 30, 2012 7:59 pm 
Offline

Joined: Sun Jul 02, 2006 11:23 am
Posts: 10
jaguar,vettes&sprints wrote:
I foun the vacume line to the booster was clogged not leaking
Check it out remove hose and try to blow through it.....jv&s
.
.

when I blow through it I'm met with small initial resistance but then flows freely, I was thinking that perhaps a loss of vacuum pressure somewhere was creating the lack of booster assistance but am not certain that the two are related in anyway.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group