TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Mon Oct 23, 2017 8:23 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sat Sep 07, 2013 1:35 pm 
Offline

Joined: Sat Sep 07, 2013 1:15 pm
Posts: 2
Location: United States
Ok this car is really hard to start and flooding. It has a new timing belt and I know it is in time. The only clue I have is I am getting code P1510
ECM Back-Up Power Supply Malfunction. How do I fix this? My son really needs his car back and I need his out of the way so I can start working on my truck again. Any help will be greatly appreciated by me and him as well. Ty and have a great day!


Top
 Profile  
 
PostPosted: Tue Sep 10, 2013 1:13 am 
Offline

Joined: Fri Feb 13, 2009 7:10 pm
Posts: 880
Location: Vancouver, WA
I'll look into this tomorrow but my gut says faulty ecm

_________________
98 swift 1.6 16v swap
03 cobra bolt ons
97 3000gt vr4 e85, high comp, bolt ons
too many others to list


Top
 Profile  
 
PostPosted: Tue Sep 10, 2013 4:28 pm 
Offline

Joined: Fri Feb 13, 2009 7:10 pm
Posts: 880
Location: Vancouver, WA
Image

pin 14 is white wire on 26 pin PCM connector. fed 12 volts from fuse 23 (15A) in under dash fuse box.

_________________
98 swift 1.6 16v swap
03 cobra bolt ons
97 3000gt vr4 e85, high comp, bolt ons
too many others to list


Top
 Profile  
 
PostPosted: Tue Sep 10, 2013 4:40 pm 
Offline

Joined: Thu Jul 20, 2006 7:17 pm
Posts: 1405
Location: Alberta, Canada
Apart from the trouble code, take a quick peak at the map sensor and vacuum line going to it. They run horribly and rich if at all if that line gets disconnected or damaged for any reason. It's on the firewall, little sensor with one vac line going to it and one connector. Don't have a pic, but google or a search will clarify I'm sure. It needs to have vacuum to it at all times.
Looks like that code is easy enough to diagnose. It's a simple test to check that circuit. Of course check all fuses, under dash and under hood.

_________________
1995 Swift w/16V 4.39s, 3tech cam, Esteem t-body, Header, needs more.
1995 Gt Mustang "Boss Shinoda" package.
1999 F150 4x4 Supercharged
1967 Mustang 428 auto, never ending expensive project
1993 Civic si h22a, fell in my lap, couldn't resist!


Top
 Profile  
 
PostPosted: Wed Sep 11, 2013 7:55 pm 
Offline

Joined: Sat Sep 07, 2013 1:15 pm
Posts: 2
Location: United States
Thanks guys will try to get it checked this weekend and let you know.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group