TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Oct 18, 2017 10:29 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Fri Oct 22, 2004 12:04 pm 
Offline

Joined: Thu Oct 21, 2004 5:35 pm
Posts: 2
Location: texas
Here's what I've done. Replaced all the ignition components (cap, wires, coil, plugs). Also has a new fuel filter.

The car starts and runs great for about 10 minutes then it dies. It seems like it dies after it fully warms up. After it died I started looking for the problem. I narrowed it down to the ignition. After starting and dying the ignition only throws one measly spark then no more. If I let the car sit for a while it will start up again. After tracing all that could be wrong with the ignition system I've come to my own personal conclustion that it has to be the ignitor.

Anyone else have any ideas?

BTW, if I do the code lookup thing I get a code 41

Service manual says:
Ignition Signal: No signal from ignition coil for two seconds with engine starter switch turned on.


Top
 Profile  
 
PostPosted: Fri Oct 22, 2004 2:03 pm 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11669
Location: columbus, ohio
in reference to your post here and at the t3 haven, it sounds like your diagnosis is spot on. your igniter is not firing the coil or your ecu is not firing the igniter.

DJDave has some reference material at:

http://www.execulink.com/~crdreyer/turbo/

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
PostPosted: Fri Oct 22, 2004 5:00 pm 
Offline
User avatar

Joined: Fri Apr 09, 2004 2:27 pm
Posts: 763
Location: Toronto, Ontario
You have a new coil huh? Brand new? those simptoms kinda sound like the coil is bad when the coil is bad and the car heats up then it shuts down, althought it may be a new coil sumthings they come bad from factory or it might have been dropped at the part store, I once bought a ss super coil (with the oil) and was craping out on my I put my regular coil back on and the car was good as new. I returned that shitty coil. Check ur coil or see if u can get hold of another 1 to test it out if I doesn't shut off after then 10 mins then its was ur coil. It also could be the ignitor, is it hot when it shuts off? maybe its not properly heat sinked? if its hot make a heat sink out of aluminium or sheet metal that'll do the trick :wink:

_________________
91 suzuki swift GT - UNDER PRESSURE Summer Sleeper.
04 Acura tsx - daily driver.

Turbo lag? huh? nah! just traction lag :censor: :furious:

psssshh! don't tell anyone :ez_evil:

BTW GTi = Great Tiny Import :P


Image, Image


Top
 Profile  
 
PostPosted: Sat Oct 23, 2004 1:03 am 
Offline

Joined: Thu Oct 21, 2004 5:35 pm
Posts: 2
Location: texas
Thanks for the tips. I'm going to do some more testing tomorrow.

When the problem happens have any tips for testing the coil to make sure its not the problem? I need to pin-point the actual issue so I know what to replace...


Top
 Profile  
 
PostPosted: Sat Oct 23, 2004 2:55 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11669
Location: columbus, ohio
the igniter, being a solid state device, might be heating up and crapping out but generally they seem to just quit and never hit another lick. the coil could heat up and go away, then cool down and come back.

is the car running on the ecu open loop and then shutting down when it runs closed loop? unplug the o2 sensor and run the car and see if it still quits on you.

i've been hanging with you on 2 sites and you say it throws a code 41 - ignition error, and that would indicate the igniter not sending a pulse to the ecu. the pulse is generated by the igniter and not the coil, so it would further point the finger at the igniter.

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group