TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Fri Oct 20, 2017 12:23 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 29 posts ]  Go to page Previous  1, 2
Author Message
PostPosted: Sat Nov 30, 2013 4:23 pm 
Offline

Joined: Thu Feb 22, 2007 10:51 pm
Posts: 153
Location: boise id
Ok i had a chance to do some more diggin. I took the air filter off and watched the maf while i played with the ut throttle and it seems to move instantaneously. I did the warm engine compression test with the throttle at wot and the numbers thia time were 151/147/146. So not thinkin its the bottom end. While doing the comp test i changed out the auto lite spark plugs for ngk ones oem number and ot now idels a lot better but still low. It just doesn't die now. With the higher idle i checked timing and it was at 15 deg. I pulled it to 10 and it got a little better. I pulled off the charge pipe and looked in the throttle body. Its very clean before the flaper and a bit dirty after it. But i can see the metel of the intake so its not super gummy or anything.


Top
 Profile  
 
PostPosted: Sun Dec 01, 2013 3:30 am 
Offline

Joined: Thu Feb 22, 2007 10:51 pm
Posts: 153
Location: boise id
So now there is a new development. I let it cool down after the compression test and checking everything out and a short drive. Went out to drive it to work and now the throttle is an on off switch. Not sure if this is a connected issue or a new one. :huh:


Top
 Profile  
 
PostPosted: Sun Dec 01, 2013 10:59 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11669
Location: columbus, ohio
bad tps, connector, or wiring.

you really need to get a factory service manual (fsm) and work the diagnostics from the fsm's flow chart.

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
PostPosted: Tue Dec 03, 2013 2:45 pm 
Offline

Joined: Thu Feb 22, 2007 10:51 pm
Posts: 153
Location: boise id
So i got to tginking about it and asked my dad and as far as either of us could remember it had the factory o2 sensor in the exhaust. Changed that out this morning and wala it idles at 800ish rpm as of current.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 29 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group