TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Oct 18, 2017 10:23 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Thu Aug 28, 2014 9:40 pm 
Offline

Joined: Sun Jan 01, 2012 4:47 pm
Posts: 76
Location: Boston, massachusetts
Hello Guys.
Im not a mechanic and have very little knowledge about how my car works, but its been fine for my 3 years of ownership.
A couple of weeks ago i noticed that when in accelerate on second gear and it passes 4.000 rpm the blow off valve goes off and the car looses power for a second and the check engine light turns on, then it lights off and everything continues working normally.

What could it be?

Any help would be greatly appreciated.

Esteban P.


Top
 Profile  
 
PostPosted: Fri Aug 29, 2014 11:04 am 
Offline
User avatar

Joined: Wed Aug 09, 2006 6:37 pm
Posts: 784
Location: Palmdale, Ca
See this thread

_________________
1987 Chevrolet Sprint Turbo under construction


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group