TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sun Oct 22, 2017 9:08 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Lost power.
PostPosted: Tue Oct 14, 2014 4:49 pm 
Offline
User avatar

Joined: Tue Feb 07, 2006 2:19 am
Posts: 31
Location: Pacific Northwest
I was driving home yesterday, 1990 Turbo sprint started losing power. Pulled off the road turned off. Started once, got going, lost power again, pulled off road and left her there. I have to go back to pick her up. Could it be a fuel issue? Fuel filter plugging? I am suspecting my fuel tank needs to be replaced, possible rust in tank causing plugging?

If there is water in the tank would it be easy to pump out? For the life of me I cant remember off hand where the fuel filter is located. Any info appreciated.


Top
 Profile  
 
 Post subject: Re: Lost power.
PostPosted: Tue Oct 14, 2014 6:55 pm 
Offline
User avatar

Joined: Tue Jul 03, 2012 12:19 pm
Posts: 344
Location: vancouver island, canada
Sounds like full problem to me. The filter is right beside the tank on the drivers side I beleave. And yes. If you have water and or rust in the tank it will cause problems.if your tank is full what I do is disconnect the fuel filter and run the hose into a gas can. Pull the fuel pump relay and jump the pink and white with blue stripe wires. At least for my 91 that's the colors but it should be the 2 terminals at the front. Then turn the key to run and let the pump drain the tank. If you do have rust in the tank more then Likely you will need a new sock for the pump as well as a new full filter. And let's hope the pump is still good. Might want to check the presume before hand

_________________
92 geo metro 1.0L 5 spd. 2 dr Soon to be my turbo swap car. (Dragonfly) sold
91 pontiac firefly, 1.0L 2dr auto. stock. (The crap can) sold
91 chevy sprint. 1.0L 5 spd. My first turbo swap. (Red rocket) now the purple nurple
95 geo metro. 1.3L auto parts car. (Scrap)
91 chevy sprint turbo, blueboy keeping it "stock"


Top
 Profile  
 
 Post subject: Re: Lost power.
PostPosted: Sat Nov 15, 2014 8:40 pm 
Offline
@ssclown

Joined: Sat Dec 05, 2009 7:58 am
Posts: 756
Location: not here
I've had more than one 1985 to 1988 Sprint, Forsa, or Firefly do that and I wasted a whole pile of time thinking it was a fuel problem and trying to solve that when in every case it turned out to be a faulty igniter(or something like that inside the distributor) which started failing once it warmed up. ( electrical resistance in a metallic conductor increases with temperature). Replacing the distributor with a known to be good used distributor solved the problem every time. Wait 'til the car is stone cold and try starting it.


Top
 Profile  
 
 Post subject: Re: Lost power.
PostPosted: Sun Nov 16, 2014 12:05 am 
Offline
User avatar

Joined: Tue Jul 03, 2012 12:19 pm
Posts: 344
Location: vancouver island, canada
Yes. If it only does it hot I would look at ignition. It sounds like what mine was doing when my pump was not putting out enough pressure. The way I had to test it was to remove the hood and use a presume gauge zip tied to the firewall and went for a drive. Was dropping to 20 psi over 3000 rpm. If you have water in the gas tank about the only way is to drop it. It a hard job on these cars. I can have mine out in about 7 min. But if it's never been out could be fun with rust. Be carefull not to break Any of the 4 bolts and have new hose clamps. Another thing to be carefull of is the sending unit tube rust and can break really easily. I just removed most of mine and ran rubber tubing. I would start at fuel pressure and go from there. And there is a fuel filter right beside the gas tank on the drivers side. Check it as well. If it's plugged it will run but lose pressure/flow in the higher rpms

_________________
92 geo metro 1.0L 5 spd. 2 dr Soon to be my turbo swap car. (Dragonfly) sold
91 pontiac firefly, 1.0L 2dr auto. stock. (The crap can) sold
91 chevy sprint. 1.0L 5 spd. My first turbo swap. (Red rocket) now the purple nurple
95 geo metro. 1.3L auto parts car. (Scrap)
91 chevy sprint turbo, blueboy keeping it "stock"


Top
 Profile  
 
 Post subject: Re: Lost power.
PostPosted: Sun Nov 16, 2014 9:46 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 824
Location: walsh,alberta,canada
I have had my share of bad ignition modules (inside dizzy) on the turbo cars. they would always start and idle fine, but would cut out over 3,000 or 3,500 rpm.
even the dealership could not figure it out, they blamed it on one cylinder having lower compression. by 7 psi. asshats.
did my own troubleshooting on the car, finally I swapped the dizzy, and bang! 7500 rpm no problem!
I have had 3 of them go bad over the last 15 years, all on different turbo cars. but never on a non-turbo?
hmmmm.......

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group