TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Tue Nov 21, 2017 1:06 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Sun Sep 06, 2015 11:30 am 
Offline

Joined: Fri Dec 05, 2014 5:39 pm
Posts: 426
Location: United States
Just wondering what my vacuume should be with a cam in it? I used to have 20lbs and now have 16lbs this seems right to me but want to make sure.
I was getting a vacuume leak at my blow off valve hose due to the wrong hose clamp. After I fixed it it ran great. Started it the other day and was running rough again. Went through the whole intake tract checked vacuume hoses ect but found nothing leaking.
I noticed my fuel pump was cycling 5 or 6 times. This told me I had a leaking injector.
Than it hit me. After I went riding last time I installed a water separating spin fuel on filter. Seems I got some crap in the fuel system while doing this. Once I revved it several time and held the throttle open it seems to have cleared up.
Idles smooth and fuel pump only cycles once or twice when turning the key on.
Anyway that's what brought me to my vacuume question.
Thanks Edd

_________________
"She wasn't much of a wrestler,,, but u should of seen her BOX"


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group