TeamSwift
http://www.teamswift.net/

Injector #2 question
http://www.teamswift.net/viewtopic.php?f=32&t=62990
Page 1 of 1

Author:  CMA [ Sun Sep 03, 2017 8:39 pm ]
Post subject:  Injector #2 question

Just curious... Is it normal that injector went bad than #1 and #3?

I recalled to replace the injector #2 last summer due to misfire... now at this time, injector 2 stuck closed again... Is it just bad luck or what?

I meant how the hell injector goes bad?


It's MK2 Turbo. (1989-1991 G10T)

Author:  87paperchuckerTurbo [ Thu Sep 28, 2017 6:18 pm ]
Post subject:  Re: Injector #2 question

So this isn't directly answering your question however very useful information when working on an older fuel injected vehicle(also applies to new however less common to find). If you have water in your fuel and it makes it to your fuel rail the furthest injector from the fuel supply will be the first to fail more times than not I've seen a car come in three times with the same injector failing before the customer allowed us to drop the tank and flush the fuel system after that the issue was resolved.

So in your case to have #2 failing you've got my interest peaked. When you say clogged is it fuel deposite build up or rust? When you look at the inlet and outlet is there any rust visible? how did you determine that the injector had clogged? did you replace the first one or is a shop undertaking the diagnosis and repair? Were the screen filters present in the injector when removed? Do you run your cars fuel near empty often? Is the injector electronically sound with the same resistance as the other two?

I know that's allot of questions but as I said you've got me curious. Let's figure this thing out. :D

Author:  CMA [ Thu Sep 28, 2017 6:57 pm ]
Post subject:  Re: Injector #2 question

The answer is 6x injectors are not passed the FI test... after FI tested... 2 FI died... I don't know which... They don't tell me :evil:

After installed the cleant FI and huge different...


My best guess

1) poor atomized FI... can't run the engine well without cold injector active.
2) no FI service... very high km.
3) dirty fuel
4) water/rust in the fuel tank

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/