TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Tue Oct 17, 2017 8:17 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 11 posts ] 
Author Message
 Post subject: 1996 Geo metro 1.0L
PostPosted: Wed Jun 04, 2008 2:02 pm 
Offline

Joined: Wed Jun 04, 2008 1:25 pm
Posts: 11
Location: SC
I have a 96 Metro 5 speed the mpg use to be close to 45 per gallon not I am only averaging 35 to 40. I have changed all filters and put new plugs, wire, distributor cap and rotor on the vehicle. Is there anything else I should be looking at. Also as a side I am getting a lot of blow by and its using about a quart of oil a week. I have chaged the PCV and no oils leaks are visible.


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Wed Jun 04, 2008 5:13 pm 
Offline

Joined: Wed Jun 04, 2008 4:19 pm
Posts: 6
Location: King George, VA
Not an expert...but might look into piston rings...is it blowing smoke out the tailpipe?


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Wed Jun 04, 2008 7:56 pm 
Offline
User avatar

Joined: Tue Apr 08, 2008 9:08 pm
Posts: 1254
Location: Ashtabula, Ohio
Best thing you can do right now is get a compression test on all 3 cylinders wet and dry and post the readings here.

_________________
Image
  • EcoMudder - Geo Metro Mudder
  • Project page
  • Build Video
  • 1991 4 Door Truck Conversion
  • Modified Suzuki 1.0L Engine
  • High Stall 3200 RPM Converter
  • Auto Trans with Welded Differential
  • Custom Exhaust and Intake System
  • 6" Suspension Lift & Weight Reduction
  • 27" Kenda Executioner 6 Ply ATV tires


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Thu Jun 05, 2008 8:39 am 
Offline

Joined: Wed Jun 04, 2008 1:25 pm
Posts: 11
Location: SC
No smoking at all. I have changed the front seals and the timing belt and the distributor O ring. The reason I say blow by is because if you run your hand along the back of the hatch it will get black. I plan on doing a Compression test in the next week or so and will definatelly post the results. This site has helped with other problems so hoping I can figure out whats going on. Thanks for the input.


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Fri Jun 06, 2008 12:48 pm 
Offline

Joined: Sat Nov 18, 2006 12:01 am
Posts: 14
Location: Near Wichita, Kansas
Black usually means too rich on fuel, not necessarily oil burning. Have you seen you check engine light on? Could be an Oxy sensor gone out. When you start the car next time, turn the key to on and see if your check engine light comes on before you hit the starter. If not, you may have a burned out bulb and been getting warning from the ECM that you were not seeing. Even so, it may be possible for the O2 sensor to go out without getting a light. Just a place to start.

_________________
Image
97 Red 2dr Metro, 1.0L 5spd
93 Green 2dr Metro, 1.0L 5spd
92 Blue 2dr Metro, 1.0L Auto
Donors:
92 Blue 2dr w/5spd (Dead from frame cancer)
92 Red 4dr w/Auto (Just Dead!)


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Sat Jun 07, 2008 11:19 am 
Offline

Joined: Thu Jun 05, 2008 10:47 am
Posts: 24
Location: so. in.
O2 sen. ???? if it is running rich it will wash down the cylinders ans use more oil than normal


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Tue Jun 17, 2008 9:41 am 
Offline

Joined: Sat Nov 18, 2006 12:01 am
Posts: 14
Location: Near Wichita, Kansas
COMP wrote:
O2 sen. ???? if it is running rich it will wash down the cylinders ans use more oil than normal


Nice, but not quite true. A blown O2 sensor won't cause a wash of gasoline but will cause the computer to shoot slightly more than normal. This lowers your milleage. Now, a bad injector o-ring, that could allow a lot more fuel than is needed to get by. This would affect your mileage, wash your cylinders, and possibly not set off the O2 sensor code.

_________________
Image
97 Red 2dr Metro, 1.0L 5spd
93 Green 2dr Metro, 1.0L 5spd
92 Blue 2dr Metro, 1.0L Auto
Donors:
92 Blue 2dr w/5spd (Dead from frame cancer)
92 Red 4dr w/Auto (Just Dead!)


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Tue Jun 17, 2008 4:37 pm 
Offline

Joined: Thu Jun 05, 2008 10:47 am
Posts: 24
Location: so. in.
metromad wrote:
COMP wrote:
O2 sen. ???? if it is running rich it will wash down the cylinders ans use more oil than normal


Nice, but not quite true. A blown O2 sensor won't cause a wash of gasoline but will cause the computer to shoot slightly more than normal. This lowers your milleage. Now, a bad injector o-ring, that could allow a lot more fuel than is needed to get by. This would affect your mileage, wash your cylinders, and possibly not set off the O2 sensor code.

had a bad 02 on my daughters 4.6 ford and it was washing the walls down ,,200 miles and HAD to change the oil,,,,no sludge in there tho :lol: :lol:


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Wed Jun 18, 2008 2:19 am 
Offline

Joined: Wed May 28, 2008 6:24 pm
Posts: 209
Location: Escondido / San Deigo, CA
Ever figure this out?

I have a similar problem. When I first start the car it shoots some oil out the tailpipe, not much, but if you park on concreat you can see some small spots all over the ground. I'm getting 37MPG and going through a quart of oil every week or 2. My O2 sensor, and starter look like the only new parts on the vehicle.

_________________
Image


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Mon Jun 30, 2008 7:59 am 
Offline

Joined: Wed Jun 04, 2008 1:25 pm
Posts: 11
Location: SC
I am still working on this issue. I did the compression test and it appears form what has bee posted I may have burnt exhaust valves. My EGR was clogged so I cleaned but I do not have oil shooting out the back and no smokng at all. I get a black film on the hatch thats why I said blow by(may not be the right term.) I am also the code for my crank psoition sensor and my timing may be a little off but I am going to a friend to help with that since I am leary of timing.


Top
 Profile  
 
 Post subject: Re: 1996 Geo metro 1.0L
PostPosted: Mon Jun 30, 2008 11:54 pm 
Offline
User avatar

Joined: Mon Nov 14, 2005 9:37 am
Posts: 1172
Location: Memphis, TN
more than likely a burnt exhaust valve.

_________________
94 Swift GTi 5spd
94 3cyl automatic 4 door


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group