TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Thu Oct 19, 2017 8:52 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Bad Economy?
PostPosted: Sun Mar 08, 2009 10:08 pm 
Offline

Joined: Sun Feb 15, 2009 11:30 pm
Posts: 56
Location: Canada
I own a 4 cyl 1.3 automatic hatchback LSi with 168k and i consistantly drive city and consistantly get about 350km to a tank, quickly doing the math at a 40L tank thats more than 10L/100km... other than driving habits, what could be the leading cause of my fuel consumption? Ive tried laying off the gas and i only get about 20KM in extra economy. I realize that city driving is a killer for economy.. but i would think my economy should be a little better than 10L considering ive seen this same model rated at between 6.5 and 7 L/100km city

keep in mind
my tires are at maximum PSI for economy
the wheels have been recently alligned
new seals installed (except for main engine seal)
Transmission makes noise in RD2L but not P or N

hopefully I can somehow improve the mileage without sounding like an idiot :huh:


Top
 Profile  
 
 Post subject: Re: Bad Economy?
PostPosted: Mon Mar 23, 2009 9:01 am 
Offline

Joined: Thu Mar 27, 2008 6:52 am
Posts: 228
Location: Fort Atkinson WI
I owned a 97 geo metro with the 1.3 and auto. The best I could manage is 32MPG. I sold the car to some friends and they get 37+ on the drive to work and back on the freeway. i will say this if that trans is making noises that could be a big part of your problem. Have you drained the fluid and changed the filter in it lately? ever? The 1.3L is a smooth motor but that auto sucks.

_________________
Just when I thought I was about to get back on my own 2 feet life kicked me in the shorts.

94 GEO METRO PARTS FOR SALE EVERYTHING MUST GO!!!!
94 XFI rust bucket
96 Honda Accord


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group