TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Tue Oct 24, 2017 3:31 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: fuel problem
PostPosted: Tue Sep 02, 2014 6:00 am 
Offline

Joined: Wed Jan 29, 2014 1:18 am
Posts: 212
Location: Slovenia
hello!
in saturday i drove to work with no problems, but after work engine didn't want to start.. starter worked ok but engine didnt even try to start..
few hours later i came back to car with tools and everything but car started with no problems.. then it ran whole weekend with no problems, for about 150km..
yesterday i tried to start it but in 1sec after start it died.. later i tried to block return fuel line and it started.. it was late so i went to bed and today i tried again and with open return line it's like it was in saturday after work, and with blocked return line it want to start but cant..

so, what could be problem? fuel pump, fuel filter or fuel pressure regulator? anything else maybe?

thanks


Top
 Profile  
 
 Post subject: Re: fuel problem
PostPosted: Sun Sep 07, 2014 9:44 am 
Offline
User avatar

Joined: Mon Apr 18, 2011 12:44 pm
Posts: 221
Location: Portage La Prairie, Manitoba,Canada
Sounds like a fuel pump to me! To diagnose listen when you first turn the key on, u should hear the pump run for about 3 seconds and then shut off.

To troubleshoot next time it happens take a soft face mallet and give the fuel tank a wack or two near where the pump is in the tank! If it is a intermittent pump then usually it will kick in after a wack or two! Just my personal experience! Good luck!

_________________
1999 suzuki swift ice race car... Dohc engine conversion, 3tech 222/365 cams, bored tb, aasco lightweight flywheel, 4.56 final drive, Welded Diff, cultus intake, srd 4to1 header, spool forged rods, Megasquirt PNP, H&R sport springs and Koni yellow shocks.


Top
 Profile  
 
 Post subject: Re: fuel problem
PostPosted: Sun Sep 07, 2014 11:16 am 
Offline

Joined: Wed Jan 29, 2014 1:18 am
Posts: 212
Location: Slovenia
got new pump and filter, but even before i changed them i replaced ecu (needed to change it anyway to put sandro's chip in) and it look like engine work normal now..
it might be bad contact or something like that in ecu or somewhere in ecu harness..


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group