TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sat Nov 25, 2017 12:26 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: new to me (?) 89 gti
PostPosted: Fri Dec 19, 2014 5:56 pm 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11675
Location: columbus, ohio
given the symptoms and your description of the rust in the fual system i would probably start with the injectors. it sounds like they are loaded with crap and the pintles aren't sealing shut. that would cause heard starting, the injectors would start leaking fuel the minute the key was turned to position 1 and the fuel pump primed.

if you press the throttle pedal down while cranking the started the ecu would go into flood clear mode and shut off the injector pulses. the engine would start on the raw fuel that had been leaked.

on the injectors' inlets there are little baskets that collect trash. those need to come out and to be replaced. i'd recommend that you locate an injector cleaning business and have them rebuilt, ultrasonically cleaned, and flow tested. once you are sure that the rest of the fuel system is clean and free of crap, install the refurbished injectors.

i always pull the gas cap off and blow the supply and return fuel pipes from the engine bay towards the back after getting both ends disconnected. i put the ends of the hoses at the left rear of the car into a metal can to collect the dead spider bodies. =)

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Sat Dec 20, 2014 9:49 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
I do have 4 new injectors that were in the car, plus the original fuel rail. the current injectors/ fuel rail I bought from a member here, all I did was swap out the new for his old.....and then the car ran perfectly on all four, until it got down to the bottom of the tank. sure, the filter was stopping the large chunks of rust, but the gas that came out after the filter was still pretty murky.
good call, richard :clap: will have to look for a place to clean them. might even try swapping the new ones in, its not that much work to do that.

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Sat Dec 20, 2014 11:43 am 
Offline

Joined: Thu Jul 20, 2006 7:17 pm
Posts: 1410
Location: Alberta, Canada
There is a place in Edmonton area that I got a pamphlet for at a swap meet. Dukes injector and carburetor service. Phone number 1-780-960-3388. I haven't tried them yet, but might be worth checking on, not sure if there is a shop your direction or not. Sending a spare set might be easy and shouldn't be terribly expensive to get cleaned properly. Another thing you can do is block your return line and see if pressure still drops overnight. This will tell you if regulater is leaking. Technically you can block supply line if you are tapped in by injectors, that will show if pump check valve is not holding pressure.
Also, if pump or regulator is leaking, cycling the key a few times might make it start easier, giving a hint as to whether it's lack of fuel, or a flood condition causing the hard starting. It could easily be both given the rusty tank on that one.

_________________
1995 Swift w/16V 4.39s, 3tech cam, Esteem t-body, Header, needs more.
1995 Gt Mustang "Boss Shinoda" package.
1999 F150 4x4 Supercharged
1967 Mustang 428 auto, never ending expensive project
1993 Civic si h22a, fell in my lap, couldn't resist!


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Thu Jan 29, 2015 8:56 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
I have not got around to the starting issue yet...been busy at work :roll:
but I had another issue come up, as I was coming to work last Friday I slowed down thru a small town, and the car started to stumble, then just died. tried to re-start, and it would fire somewhat and BACKFIRE thru the exhaust.... :huh: managed to get it off the highway, called the boss and asked him to bring a truck and trailer to rescue me, as I wasn't far from work.
first thing I did was check the timing, it was ok...then pull the plugs, do a compression test....210 psi on all 4 cylinders 8) then I checked the cap and rotor.....
:shock: as soon as I took the cap off I found my problem....there was a thumb sized hole thru the side, smashed contacts, and the rotor was missing all of the metal contacts :huh:
no problem, I will order new cap & rotor...if I could...one cap in town, but NOBODY has a rotor....I don't have any spares....I found one rotor on the west coast, 2 out east :x
air freight, wait until Wednesday for the rotors to arrive...caps showed up Tuesday....

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Fri Jan 30, 2015 9:05 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
so I put the new parts on, fired the car up, and drove home. when I got home, the car sputtered a few times, then died. same symptoms, back-firing and all. :huh:
pushed it into the shop, took the cap off, and it was destroyed inside, the screw for the rotor was snapped off in the rotor shaft, PLUS I found a extra screw inside the cap :huh:
upon further inspection I noticed that there were 2 small screws missing from the module below the rotor :shock: and the rest of them were all loose, ready to come out :x
drill out the broken screw from the rotor shaft, then dig thru my random parts to find one. removed one screw at a time from the module, added red Loctite to all the screws, installed new rotor with red Loctite, new cap (again, thank god I ordered 2 of each!) and fired it up.
I never had the dizzy apart. it was new on the car when I bought it. there was no Loctite on the screws when I removed them.
somebody wasn't doing their job when they assembled it. :evil:

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Mon Apr 13, 2015 6:22 pm 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
so I finally put the car in the shop to work on it. running rough on 3 cylinders, I had the hood open, blew the dust off of the engine, and poked around a bit. pushed on the injector connectors, and the #4 cylinder was loose.....as soon as I pushed on it, the cylinder came to life, the engine purring like a kitten.
drove around the block, car pulls hard like it should...
dammit....
oh well. need to pull the cams to fix the oil leak, sending the cams to mike. 8)
pulling the ecu for chip upgrade :twisted:
install new water pump(I did belt earlier, but not the pump...it may be leaking....)
I put another resonator on it earlier this year, but I noticed right away a power loss....it may get removed.
cant wait to drive it with the parts installed....

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Sat Apr 18, 2015 11:33 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
pulled the cams this morning. original seals, they had cracked lips, so old and stiff that when the lips were pushed on from the inside they would crack even more!

then onto the water pump. it looks new-ish. leaking from paper gasket, some of the bolts were loose.....I pulled it off, only to find that there were 2 paper gaskets AND what looks like copper gasket spray between them....or house caulking....the original gasket was still there, corroded to the block....

next is the ecu, get it pulled and ready for socket/SANDRO'S chip.....maybe a moates cable and remote mount.....

as for the valve cover, not sure if to paint it, or polish it.....I did a valve cover on a mitsu 2.6 full polish, that was well over 20 hrs....but damn it looked nice! that was over 15 years ago, I saw the truck last week and it looked just as good!
the owner told me it was custom polished, and I said,''i know, I did it''! he had no clue it was my old truck!

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Sat Apr 18, 2015 12:26 pm 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
Attachment:
009.JPG
009.JPG [ 127.41 KIB | Viewed 1921 times ]

Attachment:
010.JPG
010.JPG [ 109.76 KIB | Viewed 1921 times ]

that took about a half-hour. put it in a soft-jawed vise, used a orbital sander, first pass 220 grit, 2nd pass 600 grit, 3rd pass 1200 grit, then mothers aluminum polish(by hand).
will try power polisher later.
polished a small spot on the valve cover.......hmmmm....

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Sun Apr 19, 2015 7:14 pm 
Offline
Make love, not moderators
User avatar

Joined: Sun Aug 25, 2002 5:26 pm
Posts: 1936
Location: Etobicoke, Ontario
I've always been partial to the sandblasted look on a valve cover..


Just have to make sure you don't get any sand on the under side...

Attachment:
ENGINE9.JPG
ENGINE9.JPG [ 36.76 KIB | Viewed 1904 times ]


Clearcoated after sandblasting.

_________________
"Don't argue with stupid people. They just bring you down to their level and then beat you with experience."


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Tue Jun 16, 2015 8:45 pm 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
so its been awhile, gathering parts and finding time...
got a pair of 3-TECH cams 8)
got a sandro's chip 8)
got some parts from moates...ribbon cable, zif socket and external mount..... 8)
installed cams, new seals, new water pump, new tensioner & belt, cam sprockets. only had to adjust it once to get proper timing :-P
installed ecu ( :evil: PAIN IN THE ASS, COMMAND START/ ALARM WIRING :evil:
mounted remote socket under dash, screwed to plastic
stripped valve cover, painted white (polish would have been nice, but would have taken to long)
boss was bugging me to clean up shop, which means ''get your stuff out of here''
can't wait to hear it purr :twisted: AT 8600 RPM! :twisted:

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Mon Jun 22, 2015 7:51 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
ITS ALIVE!!!!!!!!!!!!!!!

finished putting it together Saturday after work.
it would fire, but not run......had the chip in backwards :drunk: thank god for that remote socket :wink:

now for the fine tuning....would not stay at idle, would just die....adjust throttle cable (it was loose) moved the tps , most likely too much....now have driveability issues, check engine light comes on when de-accelerating, surging at lower speeds (most likely tps)
dizzy is fully advanced.
no oil leaks.

the cams are lumpy :twisted: sounds great! THANKS MIKE!
the sandros chip works great. 8) THANKS SETH!
engine pulls hard after 4,000 rpm.....revs up very quickly :shock:
seems a little lazy at lower rpms, but a little tuning may help that. I had another resonator added before the engine work, trying to make it a little less noisy...but I noticed a power drop right away.
may remove it. (currently 2 resonators and a muffler)
still has hard starting when warm (did that before engine work) starts fine when dead cold, but when warm you need to push the gas pedal down to get it to fire...like its out of gas....it will crank and crank, but will not start unless you give it some gas..... :huh: I think its the fuel rail....I have a spare, will clean it up and install it, see if that cures that problem.
all in all, it runs great!

thanks to all the people that have helped me out with this car!

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Sat Aug 08, 2015 9:23 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
so far, so good. found out that the car DOES NOT like regular fuel...put a tank in for a test, and power was down, I could hear the engine pinging....and worse fuel mileage. back to premium.

another different thing I have noticed is that the car ''twitches'' on the rear, to the right when I go over bumps....struts are fine, tires are wearing fine, I suspect bushings.

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Thu Apr 21, 2016 8:24 pm 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
put it in the ditch this morning.
came in to hot on a 90* turn on my way to work, hit loose gravel and proceeded to go straight, went into the ditch, missed a rather large road sign ( 4 x 4 wood posts) but mowed down one of those plastic roadside warning sticks

got traction in the dirt/ grass, dropped it to 1st and punched it, tires spinning then howling in pain when I got back on the asphalt, ran it up to 8000 rpm thru the gears getting back up to speed, like as if nothing happened.

no damage to car, and thank god none to my pants :blackeye: - AND I DIDNT EVEN SPILL MY COFFEE!

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Wed May 11, 2016 8:20 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
damn thing is running funny

took off hard from work
then had no power-nothing under 3000 rpm
pulled over, engine dies- check under hood, all seems normal
engine would not re-start- had to crank forever to get it to fire. then it would start running, but with full throttle only 1000 rpm
then it would slowly climb to 3000, then would spike to redline
but when I let out the clutch it had no power, start stumbling, almost die
feathered it up to 4th gear, could not use 5th
I heard back-firing out of exhaust on de-accel
cam marks line up on cover, did not check crank (it was dark and I just wanted to get home)
sputters under 3000, then revs easy to redline with no load
then check engine light came on a few miles from home
dammit
will check ignition components, and base timing to see if the belt jumped.
:huh: :huh: :huh: :huh: :huh: :huh:

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
 Post subject: Re: new to me (?) 89 gti
PostPosted: Mon May 16, 2016 7:51 am 
Offline

Joined: Tue Aug 04, 2009 9:27 pm
Posts: 825
Location: walsh,alberta,canada
so I checked a few things last night-

pulled dizzy cap off, all looks well in there.

checked plugs- they were loose :huh: each one was a little sooty, but no oil deposits or damage.

compression is even across all 4 cylinders

looks like all the timing marks line up

hardly idles, hard to rev up, after 3 -4000 rpm it revs free.... :huh:

will dig deeper into the base timing

and check fuel pressure

_________________
89 1.0 turbo firefly
2"exhaust,no cats/resonator
3 tech 6*gear
3 tech turbo grind cam
3 tech cylinder head/w/port,polish,blend,oversized s/s valves
gti brake swap
89 white gti twincam....need I say more?
92 metro aka ''blue lump of coal''
92 white metro lsi vert
91 blue chevy sprint (gas sipper)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 6 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group