TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sat Nov 18, 2017 10:11 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Sat Oct 18, 2014 7:00 pm 
Offline

Joined: Sat Oct 18, 2014 6:47 pm
Posts: 2
Location: Battle creek,MI
Just finished putting my 93 Swift GT back on the road after it had been in pieces for a number of years, the dis-assembly done by a previous owner...Did my best to reconnect all the vacuum lines....engine block mostly just a bare block..ECU and even injectors disconnected. Bought a manual and reassembled it. It ran great when i finally got the powered. Lots of power...its a blast to drive.

Now for my problem....when the car is running for about an hour...earlier in warm weather...later in cooler weather...it will suddenly lose power...gradually...until it barely stays running. Severe backfiring can be heard, especially as I attempt to accelerate....making me think this is an electrical issue. It never stalls...idles rough....but loses almost all power. If I stop and let it cool for a period, it will run well, then quickly resort to the unfortunate set of circumstances I just described. Sometimes the symptoms will go away for brief periods of time, only to return quickly. If the car is allowed to cool for an extended time, it runs as normal...

So, what are your thoughts?...awesome car otherwise---Mike


Top
 Profile  
 
PostPosted: Sat Oct 18, 2014 9:56 pm 
Offline
User avatar

Joined: Tue Jul 01, 2008 9:46 pm
Posts: 809
Location: Great Falls ,Mt.
Check your codes and se what it's showing.


Ken............


Top
 Profile  
 
PostPosted: Sun Oct 19, 2014 8:45 am 
Offline
User avatar

Joined: Fri Sep 19, 2008 7:33 pm
Posts: 40
Location: Western Australia
Hi,

Yes, as posted above, please get some codes from the ecu. Code diagnostics can be found here: http://www.redlinegti.com/forum/vth.20895.error.htm

I'm thinking Engine Coolant Temperature Sensor (ECTS) issue.

Please let us know how you go! It helps others searching through the forum. :)

Cheers,

Drew

_________________
スズキ カルタス GT-i


Top
 Profile  
 
PostPosted: Sun Oct 19, 2014 9:03 am 
Offline

Joined: Wed Jan 29, 2014 1:18 am
Posts: 212
Location: Slovenia
there are 3 engine coolant temp sensors.. one goes to dash so you can see engine temp, second goes to ecu, so ecu know how hot engine is and third one is there to start radiator fan..
the one that goes to ecu.. blue one.. if engine temp goes too high or if you disconnect this sensor.. ecu won't let engine to rev up.. so if engine goes ok once it cool down, try replacing this sensor..


Top
 Profile  
 
PostPosted: Sun Oct 19, 2014 10:53 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11672
Location: columbus, ohio
good call on the bad clt. :wink:

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
PostPosted: Sun Oct 19, 2014 11:49 am 
Offline
User avatar

Joined: Mon Jun 16, 2014 10:10 am
Posts: 342
Location: Palm Springs, Calif
If no codes, issue is probably fuel related.


Top
 Profile  
 
PostPosted: Thu Nov 06, 2014 1:06 pm 
Offline

Joined: Tue Sep 09, 2008 2:34 am
Posts: 367
Location: Roumania
Ignition coil or igniter
It should be very hot when you lose power. After cooling it works again.

_________________
G13B 1.3L 16v 115hp


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group