TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Thu Oct 19, 2017 9:04 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Fri Feb 19, 2016 3:08 am 
Offline

Joined: Tue Mar 24, 2015 8:52 pm
Posts: 40
Location: Oregon USA
Cold start, it idles at about 500, and is weak. Operating temperature it's at about 1400.
What could be the issue? :o
It's not a new issue, just something I feel I should have addressed awhile ago. Thank you.


Top
 Profile  
 
PostPosted: Fri Feb 26, 2016 10:01 am 
Offline

Joined: Mon May 21, 2007 9:40 pm
Posts: 31
Location: NW Indiana
There is a possibility that neither of the idle control valve work/are hooked up/exist, and that the idle screw has been fiddled with to compensate. I would start be verifying you do or do not have a coolant controlled cold start valve on the firewall side of the intake by the throttle body, and then see if you have an electrically controlled idle air control valve on valve cover side of the intake towards the drivers side.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group