TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Jul 30, 2014 4:13 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Sun Aug 24, 2008 4:23 pm 
Offline

Joined: Sat Aug 23, 2008 8:02 pm
Posts: 17
Location: Schererville Indiana
I am brand new to this forum and to the metro and swift community. I recently just purchased a 94 metro HB, fell in love because my roommate owns one. My idle is just consistantly high. I honestly dont know exactly how much but i would say by comapring it to the sound of my roommates somewhere in the neighborhood of 1200 rpm.. Now as of today it just got worse, it now fluctuates in idle going up and down 3 or 4 hundred rpm once every few seconds.. Occasionally it blows out some white smoke my guess head gasket or some vaccum or emmissions problem. So i replaced every vaccum line i could think of.. Replaced spark plugs, wires, distributor cap, rotor, the only thing i did not replace was the pvc.. I cant seem for the life of me to get those two screws off that hold it in.




By the way no check engine light. Just high fluctuating idle

I will answer any questions i can. Please and if anyone here lives in chicagoland area can help me out that would be awesome.

Is there anything else that should be done about the 150k mark

What is this black canister thing that attaches to the bottom of the tbi air hat.. and goes to this little sensor to the right of the tbi? Here i found a pic however thats not an exact pic of mine mine is attached in a differernt location. Attached at bottom of page.

Lastly what is the little 1inch diameter round valve canister thing that connects between the MAP senor and the TBI

Sorry for asking a million questions on my first post.. Thanks a lot Rob Duffner !!!!


Attachments:
File comment: Black thing what are you !!
black thing what is it.jpg
black thing what is it.jpg [ 40.79 KIB | Viewed 3754 times ]
Top
 Profile  
 
PostPosted: Mon Aug 25, 2008 11:26 pm 
Offline

Joined: Sat Aug 23, 2008 8:02 pm
Posts: 17
Location: Schererville Indiana
Anyone?


Top
 Profile  
 
PostPosted: Tue Aug 26, 2008 1:01 am 
Offline
User avatar

Joined: Sat Jun 25, 2005 4:20 pm
Posts: 37
Location: Lynnwood, WA
start when is going warm?, between 1000 and 1500 rpm?, may be 1500 to 2000 rpm? lost or lack of power? If any yes, You are in the right place, problem is I don't remember where is the solution, somebody else has the same problem and Bingo! the solution, try search in carburation. good luck!

_________________
nothing sweetest than fits everywhere at 65 mph!


Top
 Profile  
 
PostPosted: Tue Aug 26, 2008 4:32 am 
Offline

Joined: Thu Mar 27, 2008 6:52 am
Posts: 228
Location: Fort Atkinson WI
Disconnect your IAC/ISC aka idle air valve if your idle drops down to normal then theres your problem. My car idled very fast too and would take forever to drop down to normal discconnected the valve and waalaa normal idle. I still get 50+mpg and it idles normal again.

_________________
Just when I thought I was about to get back on my own 2 feet life kicked me in the shorts.

94 GEO METRO PARTS FOR SALE EVERYTHING MUST GO!!!!
94 XFI rust bucket
96 Honda Accord


Top
 Profile  
 
PostPosted: Tue Aug 26, 2008 8:28 am 
Offline

Joined: Sat Aug 23, 2008 8:02 pm
Posts: 17
Location: Schererville Indiana
Where is that located on our cars? Well i think i may have come accross the problem but im not sure. That little black canister attaches to some type of switch/vacuum control... On my roommates car it pulls vacuum/air like 4 times a second at all times. Mine on my car however does absolutely nothing.

So i started toying around with the pvc valve putting my finger off and on it. And to my surprise after making the pvc valve open and close about 10 times all of a sudden i hear that thing starting to pull vaccuum out of the little black canister thing like his and my idle goes down what felt like 400rpm or so im not sure if its where it should be but it surely sounded a lot healthier and better yet the white smoke behind my car stopped as well.

I would really like to replace my pvc but the last owner or whoever worked on it stipped the screws that hold it in so bad that getting it out is more along the lines of drilling it out.

due to lack of tools at the present time id like to know if that could cause my problem cause if so then ill have someone replace it if not ill worry about something else being the problem

Can anyone answer me if the pvc and the smoke problem could be related..
And could a faulty pvc be a reason for a high idle/ creating issues between whatever that switch/ sensor is attached to the black muffler thing


Top
 Profile  
 
PostPosted: Wed Aug 27, 2008 3:23 pm 
Offline

Joined: Sat Aug 23, 2008 8:02 pm
Posts: 17
Location: Schererville Indiana
Found answer, PCV valve toast (all of its guts were gone), created loss in crankcase pressure to a point that there was not enough vacuum going to the IAC valve for it to function properly. At least thats my guess as to why.. All my white smoke stopped as well. Uncovered another problem unfortunately. But thats another post.


Top
 Profile  
 
PostPosted: Wed Aug 27, 2008 8:01 pm 
Offline
User avatar

Joined: Sat May 12, 2007 10:45 pm
Posts: 663
Location: Millbrook, Alabama
My 92 Metro is doing the exact same thing. Where is the PCV on these? Is it the thing that the hose from the valve cover attatches to, this thing?
Image




I also have lots of suction from the black tube thing also, except mine hooks up to the intake.

_________________
Image
92 Metro Turbo-G13b Swap - too much stuff to list
95 Metro 4/5 Sedan - Daily Driver Status
2014 BRZ Limited in WRB - The car payment


Top
 Profile  
 
PostPosted: Thu Aug 28, 2008 11:29 am 
Offline

Joined: Sat Aug 23, 2008 8:02 pm
Posts: 17
Location: Schererville Indiana
Yea that pain in the neck thing ...Your engine compartment looks so clean lol im jealous lol. Check for vacuum being pulled from that little muffler coming from iac idle air control valve.. Mine was being useless until i replaced the pcv... There are a million reasons for high idle on these cars.. But from the location of a piece of plastic being in such a high heat area.. makes me think these will have to replaced more than the average car. You can check that previous post of mine where i show a pic of that muffler thing by the way..


Yes and that pic that you posted is of your pcv get ready.. Steel and aluminum do a great job of binding together. You might need an impact screwdrive and a hammer.. Just a tip either way replace them with a bolt instead of a screw


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group