TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Tue Nov 21, 2017 3:50 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun Sep 04, 2011 10:01 am 
Offline
User avatar

Joined: Mon Aug 01, 2011 11:27 pm
Posts: 307
Location: Las Vegas
As you may have read in my other threads, I am rebuildin/restoring an 89 Geo Metro LSI. Well, I got the car put back together and wasnt thinking when it came time to add oil to the engine for the first time. I bought the right oil filter and a 5 quart bottle of oil.... and you guessed it, put the WHOLE 5 quarts in. It ran great at first and I thought it felt like the valves were floating every now and then whenever I reved out the motor. So, I thought that it was because of the combination of have never driven the car after the 3tech econo cam and gear and rebuilt/board out motor. I dismissed it as the sacrifice for the better gas mileage. I even emailed 3tech about the floating valves. He said, it should definitely not do that.

Yesturday, I begin to get on the freeway and punched for the first time. I have put about 150 miles on the rebuilt motor so far. I rev to about 3200 RPMs for 1st and 2nd. In 3rd, the power felt stronger so I stayed in it and as I was around 4300 RPMs... puked blue/purple smoke and instant loss of power and the motor sounded like someone shoved a cork in my tailpipe! I instantly let off the gas and start to pull off the road thinking my motor just blew out. The second I let off the gas, the smoke stopped... so I rev the motor as I find a gear and sure enough, no smoke and power was restored. So basically, the oil pushed it's way into the combustion chamber and .. yeeehaaaaa...SMOKE SCREEN!

I get to my house and look at the oil level, it is almost 1.5 inches passed the second dot on the dipstick! So, I then look up the correct amount of oil to discover my mistake. The manual says 3.5 quarts including a new filter. Doing an early oil change today...

:lol:

hope this made you smile and maybe even laugh for a second at me. We live and learn right?!

_________________
"with these powers, I could be a Super-Hero!"
...name the game and voice actor?


Top
 Profile  
 
PostPosted: Mon Sep 05, 2011 10:08 am 
Offline
User avatar

Joined: Mon Aug 01, 2011 11:27 pm
Posts: 307
Location: Las Vegas
driven about 40 miles since i changed the oil with the correct amount of oil (3.5 quarts). car runs awsome!

_________________
"with these powers, I could be a Super-Hero!"
...name the game and voice actor?


Top
 Profile  
 
PostPosted: Mon Sep 05, 2011 5:16 pm 
Offline

Joined: Tue Dec 23, 2008 3:44 am
Posts: 436
Location: castlerock Wa,
at least you over filled it. me and a buddy were workin very late at night and forgot to put the drain plug in. 6qt's of delo on the floor :blackeye:

_________________
If you ain't First your last - Ricky Bobby

1990 swift GL Twincam swap
Hyundai trans swap- in progress


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Bing [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group