TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Oct 18, 2017 7:07 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Running rich
PostPosted: Wed Jul 23, 2014 10:01 am 
Offline

Joined: Fri Oct 28, 2005 7:17 am
Posts: 378
Location: Astatula, Florida
Seems I'm running rich. Readjusted the timing and throttle back to stock - no change. Check engine light came on today and also back fired through the intake as well during acceleration.

_________________
If your using more than 3 cylinders your just wasting gas.
I spit on hybrids at stop lights.


Top
 Profile  
 
 Post subject: Re: Running rich
PostPosted: Wed Jul 23, 2014 11:55 am 
Offline

Joined: Fri Oct 28, 2005 7:17 am
Posts: 378
Location: Astatula, Florida
Correction - back fire not through intake. Pic of plugs that has been in the car for some time.


Attachments:
Plugs.jpg
Plugs.jpg [ 92.86 KIB | Viewed 1024 times ]

_________________
If your using more than 3 cylinders your just wasting gas.
I spit on hybrids at stop lights.
Top
 Profile  
 
 Post subject: Re: Running rich
PostPosted: Wed Jul 23, 2014 4:41 pm 
Offline
User avatar

Joined: Sun Jun 10, 2012 8:12 am
Posts: 157
Location: Brainerd Minnesota
Quote:
Check engine light came on today

Pulling the code should point you in the general direction. One of biggest players is the O2 sensor. Older Metros take a while to throw a code. You can run a partially bad O2 and not throw a code.

Also, those plugs look like the guy who always shifts at 2000rpms. Not good. Bring it up to 4500-5000rpms once in awhile. Your car will thank you.

_________________
.........I'll be back in a bit........
Image

Extreme Make Over....SnowFish Addiction

1991 Metro Xfi Sport, Crower F12142 Cam, +2 degrees on adjustable sprocket, .020 Over, Balanced & Blue Printed, 3.79 final drive, WhiteLine Bushings Everywhere, 185/60R14's, TBI Bridge Delete, Edelbrock Air Cleaner, Stainless Header, 2 Inch Exhaust, Magnaflow GlassPack, Swift Twin Exit Muffler.


Top
 Profile  
 
 Post subject: Re: Running rich
PostPosted: Thu Jul 24, 2014 1:03 pm 
Offline

Joined: Fri Oct 28, 2005 7:17 am
Posts: 378
Location: Astatula, Florida
Showing Code 24 Speed sensor. I have swapped the tranny. The speedometer cable housing has pulled apart and the speedometer is not working. Ran across this "speed sensor is integrated into the odo/speedometer and driven by the speedo cable". So I'm thinking that's the code problem. Unfortunately I don't think that's my running rich problem as I wasn't having that code prior and the plugs have been in the car for a while. :?

_________________
If your using more than 3 cylinders your just wasting gas.
I spit on hybrids at stop lights.


Top
 Profile  
 
 Post subject: Re: Running rich
PostPosted: Thu Jul 24, 2014 6:24 pm 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11669
Location: columbus, ohio
the vss is very important to the operation of the engine. it is a primary sensor for changing the injection mode, providing injector cutoff during deceleration, and bringing idle injection on line when the car reaches minimum speed.

if the speedo cable is broken, the speedometer drum magnet doesn't cause the reed switch to operate. zero speed counts for the ecu to operate from and it will stay in some preset form of open loop operation if it doesn't see a speed pulse signal.

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
 Post subject: Re: Running rich
PostPosted: Thu Jul 24, 2014 9:02 pm 
Offline

Joined: Fri Oct 28, 2005 7:17 am
Posts: 378
Location: Astatula, Florida
May not of explained the time line of facts coherently. Speedometer working fine before transmission swap. I damaged it during. The plugs in the pic were in the motor before the swap. Ran them with car on stands as I checked out the tranny maybe 10 minutes total. Have been running +5 degrees above stock for some time. Adjusted back to stock setting and replaced with new plugs. Changed to a 1.3 flywheel during the swap. Thinking the rich problem has been before the swap and the lighter flywheel is making it more obvious. Planning on; doing a compression check to morrow morning, find someone with a vacuum gauge, mow the yard, and swing through a salvage yard pull a speedo cable before work. :roll:

_________________
If your using more than 3 cylinders your just wasting gas.
I spit on hybrids at stop lights.


Top
 Profile  
 
 Post subject: Re: Running rich
PostPosted: Mon Jul 28, 2014 9:46 am 
Offline

Joined: Fri Oct 28, 2005 7:17 am
Posts: 378
Location: Astatula, Florida
Double checked the stock timing, fix the speedo cable and replaced the CTS - no codes :) Still running rich and backfiring :( Seems to only backfire on acceleration and under 3K :huh:

_________________
If your using more than 3 cylinders your just wasting gas.
I spit on hybrids at stop lights.


Top
 Profile  
 
 Post subject: Re: Running rich
PostPosted: Mon Jul 28, 2014 1:21 pm 
Offline
User avatar

Joined: Mon Nov 03, 2008 7:28 pm
Posts: 309
Location: concord nh
mine back fires on decell some times that is usually due to the motor being lean

_________________
02 bmw 330ci zhp
'91 Geo Metro Convertible 5-speed parts car
'92 project squishy viewtopic.php?f=36&t=43375
'98 Chevy K2500
'76 Harley Davidson FXE


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group