TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Thu Oct 19, 2017 10:22 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Wed Sep 24, 2014 4:23 am 
Offline

Joined: Wed Sep 24, 2014 3:18 am
Posts: 6
Location: Netherlands
Hi everyone,

I registered over here because I'm having a problem with my girlfriends car.
I've been busy with it for months and I can't get it resolved so I'm hoping any of you are able to help me out.

It's a 98 mk2 suzuki swift 1.3 4-cyl pretty much stock. With the addition of an LPG G3 system (so it has 2 fuel systems).

The problem:
When driving (can be any speed) the system starts to lose pretty much all power (feels like no fuel or spark). If you press the clutch the engine will die.
If you stop and try to start immediately it won't start. (will crank, but won't run)
If you wait about 10 seconds it will run again. This makes it not enough time to check if there are sparks or fuel pressure.

This can happen in a normal village (50km/h) or on the highway (130km/h) or any other speed so far.
It also happens when the car is running on LPG or on petrol. So this tells me it can't be the fuel pump (LPG has none) it isn't the injector as the LPG has it's own.

It happens on occasion, for example you can drive 200km without any problem, but you can also drive 5 with it happening twice.

The car also doesn't show a CEL when it happens.

What I did to resolve it:
Check for error codes (using the short in the diagnostic connector under the hood). This only showed 12 which should be good.
Change spark plugs
Change distributor cap
Change distributor rotor
Change high tension leads
Check if the EGR is dirty, it wasn't any more than normal, but cleaned it any way as it was now out of the car
Changed exhaust system as the CAT was in a bad shape also there was a hole in the rear silencer. And I could get it for really cheap.

Remarks:
Even though the car is registered to be from 98, i don't believe it's a 98 model, I think it's a few years earlier.
For example, it does have an obd2 port, but only the DLC protocol is available on this port (which unfortunately my scanner doesn't understand).
It doesn't have the diagnostic in the fuse box
It only has the diagnostic connector on the firewall


Top
 Profile  
 
PostPosted: Thu Oct 09, 2014 6:02 am 
Offline

Joined: Wed Sep 24, 2014 3:18 am
Posts: 6
Location: Netherlands
Nobody has any tips?


Top
 Profile  
 
PostPosted: Thu Oct 09, 2014 12:54 pm 
Offline

Joined: Fri Nov 18, 2011 10:58 pm
Posts: 75
Location: Brisbane, Australia
hey mate,
it sounds like you have a electrical fault in your ignition system.
check you dizzy internals for fauls, and check coil.
hope this helps. :)


Top
 Profile  
 
PostPosted: Thu Oct 09, 2014 5:33 pm 
Offline
Island Inbreeder
User avatar

Joined: Tue Oct 18, 2005 6:56 pm
Posts: 6347
Location: Emerald city Washington
electrical problem are very common for this year of car
there is a small fuze block located next to your battery unbolt it and check the main lead for corrosion
also the fuze box inside your car remove it and inspect it for burnt are arcing within the block it is like a sandwich
and has layers stack on each other (4) also check all conectors going to this fuze block for corrosion and Arcing..jv&s
.
.
.
I will try to find a picture

_________________
.

t3 ragtop wrote:
the 3 banger isn't at all a "grenade." it's a tough little son of a bitch doing a big job. respect it.
suprf1y wrote:
I didn't save anything.Vehicles are to me, like little boys are to Tommy.Toys to be abused for my own personal pleasure.
jrjd wrote:
"Driving a Swift GTi is like driving a bike in your house".


Top
 Profile  
 
PostPosted: Thu Oct 09, 2014 5:37 pm 
Offline
Island Inbreeder
User avatar

Joined: Tue Oct 18, 2005 6:56 pm
Posts: 6347
Location: Emerald city Washington
Image
.
see black spots.?
.
Not good
.
.
.
Image
.
Image
.
.
Image

_________________
.

t3 ragtop wrote:
the 3 banger isn't at all a "grenade." it's a tough little son of a bitch doing a big job. respect it.
suprf1y wrote:
I didn't save anything.Vehicles are to me, like little boys are to Tommy.Toys to be abused for my own personal pleasure.
jrjd wrote:
"Driving a Swift GTi is like driving a bike in your house".


Top
 Profile  
 
PostPosted: Thu Oct 09, 2014 8:16 pm 
Offline
User avatar

Joined: Tue Jul 03, 2012 12:19 pm
Posts: 344
Location: vancouver island, canada
Nice board. Bet that took a long time to find.

_________________
92 geo metro 1.0L 5 spd. 2 dr Soon to be my turbo swap car. (Dragonfly) sold
91 pontiac firefly, 1.0L 2dr auto. stock. (The crap can) sold
91 chevy sprint. 1.0L 5 spd. My first turbo swap. (Red rocket) now the purple nurple
95 geo metro. 1.3L auto parts car. (Scrap)
91 chevy sprint turbo, blueboy keeping it "stock"


Top
 Profile  
 
PostPosted: Mon Oct 20, 2014 6:28 am 
Offline

Joined: Wed Sep 24, 2014 3:18 am
Posts: 6
Location: Netherlands
Sorry for the late reply, I was on a holliday.

Everybody thanks for the replies!
I'll check the fuse boxes as soon as I get the chance and I'll update this post with what I find.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group