TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sat Oct 21, 2017 12:03 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 16 posts ] 
Author Message
PostPosted: Tue Feb 27, 2007 1:00 am 
Offline
User avatar

Joined: Thu Jul 03, 2003 11:40 pm
Posts: 174
Location: Jamaica, Kingston
low boost is 8psi and high is 18psi on the subaru wrx td04L turbo. does anyone have any experiences with this turbo or the sti turbos?

i have been running this setup for 4 months now and the only problem i have is overheating sometimes, need help with that too.

Image


Top
 Profile  
 
 Post subject:
PostPosted: Tue Feb 27, 2007 7:45 am 
Offline
The mad quebecer
The mad quebecer
User avatar

Joined: Thu Nov 07, 2002 10:06 pm
Posts: 4569
Location: Chicoutimi, Qu├ębec
You need to be more specific about your setup. What fuel management are you running? Octane rating? intercooler size? exhaust size? What injectors are you using? Stock head & cams? Compression ratio?

The TD04L is kinda small for hi boost application but you should still show healtier figures with this turbo. At least you do't need 18 PSI to get 196hp, that's for sure. I smell poor tuning here. Show us a few pictures of the setup if you can also.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 28, 2007 12:26 am 
Offline
User avatar

Joined: Thu Jul 03, 2003 11:40 pm
Posts: 174
Location: Jamaica, Kingston
i'm running a GReddy emanage ultimate, 90 octane, FMIC 22"x6"x2.5", exhaust 2"-2.5", 380cc injectors, stock head and cams, thick head gasket for lower compression. engine fully rebuild one year ago.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 28, 2007 12:42 am 
Offline

Joined: Fri Feb 16, 2007 9:59 pm
Posts: 63
Location: saskatoon, sk
if thats the power produced with a cooler 18psi, I would like to see your afr's, getting bad mileage?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Feb 28, 2007 9:51 am 
Offline

Joined: Fri Feb 16, 2007 9:59 pm
Posts: 63
Location: saskatoon, sk
actually, what throttle body are you running


Top
 Profile  
 
 Post subject:
PostPosted: Thu Mar 01, 2007 1:35 am 
Offline
User avatar

Joined: Thu Jul 03, 2003 11:40 pm
Posts: 174
Location: Jamaica, Kingston
i'm running the stock throttle body with 11.0:1 afr in boost and i get really good gas mileage off boost.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Mar 01, 2007 3:21 am 
Offline
User avatar

Joined: Wed Oct 22, 2003 7:35 am
Posts: 477
Location: West Midlands, UK
I would of thought you could lean the A/F ratio safely to 11.5:1 without any problems. Some people tune to 12:1 in boost for more power.
Phil


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 03, 2007 11:03 am 
Offline
User avatar

Joined: Thu Jul 03, 2003 11:40 pm
Posts: 174
Location: Jamaica, Kingston
i know ppl go to even 12:1 AFR but my car has been running for the past 3 years with 11:1AFR and it has never even smoked or given an engine problem. the only thing happened to me was that i had broken the exhaust camshaft last week.

Image
Image

besides that, this engine has only been pulled to change a blown head gasket.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 03, 2007 11:09 am 
Offline
User avatar

Joined: Thu Jul 03, 2003 11:40 pm
Posts: 174
Location: Jamaica, Kingston
my clutch is slipping though, forgot to add that. i damaged the gearbox seal and the gear oil came unto the clutch. this was b4 the dyno. i fixed the gearbox but nevr cleaned up the clutch, i ran out off time. but since then on high boost at about 4-5k rpm the clutch slips. i first noticed it on the dyno but i thought the wheels were skidding off the dyno. it was after going back unto the road i realised it was the clutch.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 05, 2007 1:12 am 
Offline
User avatar

Joined: Wed May 26, 2004 6:07 pm
Posts: 193
Location: South Milwaukee, WI
sweet lookin solid cams.... happy my two 1990 engines have hollows.

_________________
Project Metro
~Possibly For Sale~


Top
 Profile  
 
PostPosted: Thu Mar 08, 2007 11:17 pm 
Offline

Joined: Thu May 25, 2006 10:52 pm
Posts: 59
Location: jamaica
impressive works like these are inspiration to alot of us. on this side of the table ull get praises for your accomplishments, lol. yeah, can we see pics?

_________________
wish i had a car like runbag, wonder if he would help me build 1?


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 11, 2007 2:03 pm 
Offline

Joined: Tue Apr 18, 2006 12:30 pm
Posts: 83
Location: kingston
lol claude b thats swiffy, lol


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 11, 2007 9:53 pm 
Offline

Joined: Thu Feb 10, 2005 12:05 am
Posts: 141
Location: winston salem N.C./clearwater F.L.
how is the e manage working out ?


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 12, 2007 10:26 pm 
Offline
User avatar

Joined: Thu Jul 03, 2003 11:40 pm
Posts: 174
Location: Jamaica, Kingston
i still haven't got the wires sorted that we spoke about. the car doesn't start when i hook the wires up like in the diagram. i think its the injectors, i have low impedance.

i meant to ask you jgw, are you running low impedance injectors or high impedance?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Mar 14, 2007 9:54 pm 
Offline

Joined: Thu May 25, 2006 10:52 pm
Posts: 59
Location: jamaica
uten wrote:
lol claude b thats swiffy, lol


yeah, i know who it is, the pics are also on wheels, jus neva waan bait up di ting, u si mi. jus keepin it kool, u si mi. gwaan thru ute. mek wi si some pics.

_________________
wish i had a car like runbag, wonder if he would help me build 1?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 17, 2007 2:38 am 
Offline

Joined: Thu Feb 10, 2005 12:05 am
Posts: 141
Location: winston salem N.C./clearwater F.L.
badboyscyari wrote:
i still haven't got the wires sorted that we spoke about. the car doesn't start when i hook the wires up like in the diagram. i think its the injectors, i have low impedance.

i meant to ask you jgw, are you running low impedance injectors or high impedance?


high, 525 precision injectors


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group