TeamSwift
http://www.teamswift.net/

help!! I was desperate with mySwift
http://www.teamswift.net/viewtopic.php?f=8&t=54373
Page 1 of 1

Author:  bernard [ Thu Aug 23, 2012 11:54 am ]
Post subject:  help!! I was desperate with mySwift

hello,
I bernard from Indonesia
I had a swift 8 valve carburetor, 1990. I have a problem which is rare and difficult for decipher. here's the story.
Initially I used to race my car are legal. I just upgraded the ignition only. I use the crane cams coil igition ps 91, Supprass brand spark plug wires 9.8mm, and plugs irridium. can my car till then 8500 RPM and a maximum speed of 180 km / h. I'm quite happy because it could embarrass the B16 and B20 engines. hehehe. problems began to emerge here. moment when I started racing, my machine suddenly changed. so very heavy energy and feels like carrying a lot of load on the car
problem that arises is when the engine died and 6000 RPM when RPM drops and samapai at 4000 RPM, the engine is active again. and so on, 6000 and 4000 off on. and montirku I've replaced a few parts but the problem still persists. I replace the following part.
parts are replaced:
- carburetor
- Delco assy and cdi
- Ignition coil
- plugs
- Spark plug wires
- seleniod
- Check timming
- Fuel pump

it's all my change but the problem did not get better, I'm getting desperate and do not know what else to do. for the master please help me to find the problem where. I thank you very much for the willing to help.

bernard,

Author:  nemoskull [ Fri Jul 12, 2013 2:44 pm ]
Post subject:  Re: help!! I was desperate with mySwift

you should not be racing at 8500.
oil need 10 psi per 1000 rpm. stock USA oil presure max is 50.

Author:  Phil N Ed [ Fri Jul 12, 2013 5:18 pm ]
Post subject:  Re: help!! I was desperate with mySwift

Maybe the distributor is the problem.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/