TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Mon Oct 16, 2017 10:56 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Gearbox Issues
PostPosted: Sat Sep 28, 2013 4:40 am 
Offline

Joined: Fri Mar 22, 2013 1:09 am
Posts: 8
Location: New Zealand
Hi all

I have a 1994 swift 1.6 sedan and recently the gearbox has been acting weird. It was fine till one day when I was driving home and i went to shift into 5th but it didn't feel as if the shifter had moved far enough for it to go into gear, however it had. Now all my shifter throw distances have changed, such as if I was to shift from neutral-3rd i'd only have to move the shifter forward about 3-4cm, however if I am to shift from neutral-4th the shifter moves till the point where it runs out of room to move and doesn't feel like its fully in gear. Also sometimes it can take a while to get it into gear when downshifting into 2nd even with rev-matching and it can also take a few goes to get it into reverse.

This afternoon I pulled the trim off around the shifter and found a small red rubber ring of some sorts and a larger plastic ring that is currently in 3 pieces. Anyone have any idea what these are and where they're supposed to go?
Image

I also discovered that the gear stick has been bashing into the metal piece at the bottom as seen in the photo due to all the shift distances being out.
Image

Can someone please help shed some light on this as this is my daily driver and I am worried that I will end up doing some expensive damage if I keep driving it like this, plus its just a huge pain in the ass in general. Any info would be much appreciated thanks.


Top
 Profile  
 
 Post subject: Re: Gearbox Issues
PostPosted: Sat Sep 28, 2013 8:35 am 
Offline
Make love, not moderators
User avatar

Joined: Sun Aug 25, 2002 5:26 pm
Posts: 1930
Location: Etobicoke, Ontario
Not sure what the red thing is, but the yellowish one looks like the plastic bushing (or whats left of one half of it) that the ball from the shift rod rides on. Is the shifter arm feel sloppy when you wiggle it around while holding the base that you unbolted from the floor? You might just need to buy some new bushings for it.

If it wasn't a cable shifted transmission I would say it sounds like an engine mount issue.

_________________
"Don't argue with stupid people. They just bring you down to their level and then beat you with experience."


Top
 Profile  
 
 Post subject: Re: Gearbox Issues
PostPosted: Mon Sep 30, 2013 5:54 am 
Offline

Joined: Fri Mar 22, 2013 1:09 am
Posts: 8
Location: New Zealand
Yep it is a cable shifted transmission. The shifter arm feels pretty tight both in neutral and in gear. As for the yellowish plastic bushing should there be another half of it somewhere? Also where on the ball should it go?


Top
 Profile  
 
 Post subject: Re: Gearbox Issues
PostPosted: Mon Sep 30, 2013 6:19 am 
Offline
Make love, not moderators
User avatar

Joined: Sun Aug 25, 2002 5:26 pm
Posts: 1930
Location: Etobicoke, Ontario
One half sits on top of the ball and the other below.. The ball from the shifter is held in place by it.

_________________
"Don't argue with stupid people. They just bring you down to their level and then beat you with experience."


Top
 Profile  
 
 Post subject: Re: Gearbox Issues
PostPosted: Tue Oct 29, 2013 2:24 am 
Offline

Joined: Fri Mar 22, 2013 1:09 am
Posts: 8
Location: New Zealand
Ok so its been a while since i've updated this post but i've been so busy recently that I haven't had the time to do so. The good news however is that i've fixed the problem with the transmission. I was replacing the old leaky valve cover gasket one day when I noticed something sitting on the transmission case that looked a bit out of place.

Image

It turns out that it holds the cables that go from the shifter in place to stop them moving when you go to change gear. I still can't believe that it had been sitting on there for about 3 weeks without falling off.

Image

So after putting it back in its correct place it now works like it should. I also went to the dealer and they don't sell any of the parts that went on the shift lever and the yellowish plastic piece it apparently molded into the shifter when it is manufactured but it seems to be fine without it.
However now a new problem has appeared. Ever since the inner left cv boot was replaced the car leaks transmission fluid from where the axle goes into the transmission. It doesn't seem to be leaking much but it seems to have gotten slightly worse over time. Is this likely to be caused from the mechanic installing it incorrectly or is this a fairly common problem with these cars?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group