TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Wed Oct 18, 2017 3:31 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Mon Jan 27, 2014 2:39 pm 
Offline

Joined: Mon Jan 27, 2014 2:23 pm
Posts: 1
Location: Seattle
Hi! My first post here! I need some advice on our transaxle.

My 1991 Geo Metro 1.0 L Automatic was pouring transmission oil OUT of the bell housing/input seal.
We opened the transaxle pan and it was clean! The fluid was burned, but no parts or shavings inside the pan.
We pulled the transaxle and the torque converter.
- what looks like a race or bearing came out with the torque converter. The bearing or whatever shows signs of spinning, is steel on the outside and has copper on the inside with dimples, about 1-1/4" in diameter, and fit snugly onto torque converter shaft.
-the first time we took it all out, that piece fit snugly and came out with the torque converter.
We replaced the seal, reassembled all, the engine started well, warmed up and then started spewing trans oil again.
Disassemble again.
-This time when we pulled the torque converter, that ring stayed behind *behind* the seal (inside with the tranny) and we had to fish it out.

ANY ideas what that piece is? part no.?
AND -- where can we get an exploded diagram and if available, service procedure, for the transaxle? Not finding it online!


Top
 Profile  
 
PostPosted: Mon Jan 27, 2014 4:27 pm 
Offline
User avatar

Joined: Thu Jul 09, 2009 1:14 am
Posts: 1897
Location: Prince George B.C. Canada
Even the FSM doesn't show much for that seal on the input shaft. Could you post a picture or 2.


Top
 Profile  
 
PostPosted: Mon Jan 27, 2014 8:58 pm 
Offline
User avatar

Joined: Wed Nov 08, 2006 8:40 am
Posts: 873
Location: End of days ranch Bouse az
you need to replace the front pump bushing

_________________
it doesent have to be surrounded by water to be a island and dont forget it's a 3cyl Blow,Suck,Bang


Top
 Profile  
 
PostPosted: Tue Jan 28, 2014 2:07 am 
Offline
User avatar

Joined: Thu Jul 09, 2009 1:14 am
Posts: 1897
Location: Prince George B.C. Canada
mxmikie wrote:
you need to replace the front pump bushing

I did find this diagram.
Attachment:
Picture 1128.jpg
Picture 1128.jpg [ 441.23 KIB | Viewed 899 times ]


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group