TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Thu Oct 19, 2017 5:26 pm

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Transmission problem
PostPosted: Tue Jan 13, 2015 7:50 am 
Offline

Joined: Tue Mar 30, 2010 10:37 am
Posts: 7
Location: South Carolina
I have a 2000 Chevy Metro 4 Cylinder auto that was in a fender bender a couple of months ago. The wreck snatched the CV shaft out and bent the A arm on the drivers side. All was replaced and the car was driven for around 3 months. While driving i was turning right into a parking lot and the trans stopped pulling. No forward or reverse at normal rpm's. The car will move both directions at high rpm's (2000 - 2500 I'm guessing). Their are no unusual sounds and the CV joints are in the trans. It almost feels like the torque converter has gone bad suddenly. I had a neighbor say something about bands or solenoid. I have a old donor car with an auto in it. Any thoughts are appreciated.


Top
 Profile  
 
 Post subject: Re: Transmission problem
PostPosted: Wed Jan 14, 2015 4:21 pm 
Offline
Make love, not moderators
User avatar

Joined: Sun Aug 25, 2002 5:26 pm
Posts: 1930
Location: Etobicoke, Ontario
pierman wrote:
I have a 2000 Chevy Metro 4 Cylinder auto that was in a fender bender a couple of months ago. The wreck snatched the CV shaft out and bent the A arm on the drivers side. All was replaced and the car was driven for around 3 months. While driving i was turning right into a parking lot and the trans stopped pulling. No forward or reverse at normal rpm's. The car will move both directions at high rpm's (2000 - 2500 I'm guessing). Their are no unusual sounds and the CV joints are in the trans. It almost feels like the torque converter has gone bad suddenly. I had a neighbor say something about bands or solenoid. I have a old donor car with an auto in it. Any thoughts are appreciated.


Sounds like you are low on transmission fluid.

_________________
"Don't argue with stupid people. They just bring you down to their level and then beat you with experience."


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Bing [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group