TeamSwift

Home of the Suzuki mini-compacts ! Your Home for all things Suzuki Swift, Geo Metro, Holden Barina, Chevy Sprint, Pontiac Firefly, and Suzuki Cultus. TeamSwift is a technical performance oriented community!
It is currently Sat Oct 21, 2017 7:40 am

Underbody braces, turbos and more!

All times are UTC - 5 hours




Post new topic Reply to topic  [ 14 posts ] 
Author Message
PostPosted: Mon Sep 24, 2012 12:36 pm 
Offline

Joined: Tue Oct 25, 2011 8:43 pm
Posts: 29
Location: New jersey
Hello Everyone,

Really in need of help with my swift project It's a 1993 geo metro xfi with a swift twin cam swap. Brief history on the car bought it with the swap but had a blow motor. Head was off wire's all over the place. I bought a motor and dropped it in the car. Try to start it but it's really hard to start and run's rough the symptom's are. Hard to start once it does start willnt pass 2000 rpm Sometime when it does start, it start's up rev up to 3000 and shut's right off. The factory air intake plactic was taped and in bad shape i shopped around found suzukird. I bought a 3 stage air take took month's to get here put it on and still the same. I'm thinking it might be the maf sensor i'm hoping someone might be able to help me. I have had this car for a while and have never even drove it. Can use a vacuum diagram need to check to see if that's all in order. I'm in new jersey if there's anyone in my area would love to run together once i'm on the road Thank's in advance.


Top
 Profile  
 
PostPosted: Mon Sep 24, 2012 2:40 pm 
Offline
Moderator
Moderator
User avatar

Joined: Sun Feb 23, 2003 4:16 am
Posts: 8033
Location: Ontario, Canada
Moved to the correct forum.

_________________
Contact 3tech: g10pro@rocketmail.com


Top
 Profile  
 
PostPosted: Mon Sep 24, 2012 4:43 pm 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11669
Location: columbus, ohio
the symptoms you describe point to the ecu being in "limp home" mode. it probably needs a good ecu after you get the wiring straightened out.

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
PostPosted: Tue Sep 25, 2012 11:45 pm 
Offline

Joined: Tue Oct 25, 2011 8:43 pm
Posts: 29
Location: New jersey
Thank's ragtop for the information, Do you know if i can use any year ecu on my car from 1989 to 1994? And is there anyone on here that can maybe repair the one i have. Thank's again


Top
 Profile  
 
PostPosted: Thu Sep 27, 2012 4:52 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11669
Location: columbus, ohio
i've been able to recover 2 ecus out of about 30, patching a main ground trace on one and replacing a protective diode on another. the rest were toasted too badly to fix.

the connectors from all the gt cars, 89 thru 94, fit any of the ecus and i never had any troubles running a mk2 ecu in a mk3 car and vice versa. some guys prefer the fuel and ignition mapping on the later model cars.

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
PostPosted: Sat Sep 29, 2012 2:35 pm 
Offline

Joined: Wed Sep 01, 2010 9:39 pm
Posts: 93
Location: Grand Rapids, MI
Did you change the fuel pump?

_________________
1991 Metro GT


Top
 Profile  
 
PostPosted: Sun Sep 30, 2012 9:13 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11669
Location: columbus, ohio
the key symptom here is revving to 3000 rpm and shutting down. that's the indication of "limp home" mode and a damaged ecu. the engine will rev right to 3000 rpm and the ecu performs a hard rev limit shutting down injection and ignition.

a bad fuel pump or crapped up fuel filter doesn't cause that exact symptom.

you can read the factory service manual's troubleshooting section and see the exact parameters of failure that oldskool describes.

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
PostPosted: Sun Sep 30, 2012 10:24 am 
Offline

Joined: Sat Mar 27, 2004 4:15 pm
Posts: 3130
Location: Brantford, Ontario, Canada
i would definetly check the maf and maf wiring.

http://home.cogeco.ca/~crnolic/swift_MAF.pdf

_________________
93 Swift GT White 3Tech cams, Sandro's chip, Lightned flywheel, Genie exhaust, Cultus header, Intrax springs.
08 Civic Wife's car


Top
 Profile  
 
PostPosted: Mon Oct 01, 2012 8:26 pm 
Offline

Joined: Wed Sep 01, 2010 9:39 pm
Posts: 93
Location: Grand Rapids, MI
Hmm. From the original post, it sounded like the car fired and revved to 3k on its own. I may have been looking too far into it, but thought it may be the underlying problem, in addition to lack of fuel when the engine needed it. (again, probably over-thinking it)

...your technical expertise never ceases to amaze me, T3. :oops:

_________________
1991 Metro GT


Top
 Profile  
 
PostPosted: Tue Oct 02, 2012 5:04 am 
Offline
Suzuki Elder
User avatar

Joined: Mon Dec 01, 2003 12:47 pm
Posts: 11669
Location: columbus, ohio
thanks, but it isn't technical expertise. it's right from the troubleshooting chart in the factory service manual. :wink:

when i did my first swap i had to work through the dead ecu thing and it acted just like that, revved to exactly 3000 rpm and did a hard spark and fuel cut. if i pumped the gas pedal before the engine died, it'd catch and run again up to 3000 rpm and cut out.

a new ecu cured it. :D

_________________
1991 Blue Geo Metro Convertible highly modified 1.0L Turbo3 5 spd. - 1991 Red Geo Metro Convertible customized with a Twincam 5 spd.

My Turbo3 Project
My Cardomain Page -Ol' Blue
My YouTube Channel
My Photo Gallery
SAAB Sonett II


Top
 Profile  
 
PostPosted: Wed Oct 03, 2012 4:40 am 
Offline
Island Inbreeder
User avatar

Joined: Tue Oct 18, 2005 6:56 pm
Posts: 6347
Location: Emerald city Washington
and when you plug in your new to you ECM make sure the Battery is disconnected

_________________
.

t3 ragtop wrote:
the 3 banger isn't at all a "grenade." it's a tough little son of a bitch doing a big job. respect it.
suprf1y wrote:
I didn't save anything.Vehicles are to me, like little boys are to Tommy.Toys to be abused for my own personal pleasure.
jrjd wrote:
"Driving a Swift GTi is like driving a bike in your house".


Top
 Profile  
 
PostPosted: Thu Oct 04, 2012 2:50 pm 
Offline

Joined: Tue Oct 25, 2011 8:43 pm
Posts: 29
Location: New jersey
Hi

Just wanted to thank everyone for all the information i'm hoping to get to work on this month sometime.


Top
 Profile  
 
PostPosted: Fri Dec 13, 2013 12:26 pm 
Offline

Joined: Fri Aug 16, 2013 3:13 pm
Posts: 39
Location: Grand Rapids MI
Do you still have the ECM unit out of the Xfi


Top
 Profile  
 
PostPosted: Tue Jul 07, 2015 3:12 pm 
Offline

Joined: Tue Oct 03, 2006 10:43 pm
Posts: 720
Location: Texas 75150
I dropped a 92 DOHC into my 97 geo. I used 98 wiring harness to get sequential fuel injection.
I could not get the engine to rev past 3,000. It turned out to be a cam sensor issue.

_________________
Fainya
97 Geo Metro LSI,1.3L-GT-DOHC-16v,4.10 5-speed,A/C,170,000,suspension lowered 1",4 wheel disk brakes,15"alloy wheels with 185/50-15 Toyo's,GT bucket seats,analog oil pressure gauge,cruise control, new paint job. 40 mpg at 65 mph.
Good, fast, cheap. You only get two.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group